Revision a5f1cab4

View differences:

install.sh
38 38
	echo "  -- The installed glib-2.0 version (`pkg-config --modversion glib-2.0`) is outdated, at least 2.32 is required"
39 39
	exit 1
40 40
fi
41
pkg-config --atleast-version=1.0.1e openssl
41
pkg-config --atleast-version=1.0.1 openssl
42 42
if [ $? != 0 ]
43 43
then
44 44
	echo "  -- The installed openssl version (`pkg-config --modversion openssl`) is outdated, at least 1.0.1e is required"
......
60 60
else
61 61
	export HAVE_OGG=1
62 62
fi
63
LIBNICE=( `ldconfig -p | grep libnice.so | tail -n 1` )
64
PORTRANGE=`nm -AD ${LIBNICE[3]} | grep nice_agent_set_port_range`
63
LIBNICE=`ldconfig -p | grep libnice.so | tail -n 1`
64
set -- junk $LIBNICE
65
shift
66
PORTRANGE=`nm -AD $4 | grep nice_agent_set_port_range`
65 67
if [ -z "$PORTRANGE" ]
66 68
then
67 69
	echo "  -- Your version of libnice does not have nice_agent_set_port_range: support for configuring an RTP/RTCP range will be disabled"

Also available in: Unified diff