Statistics
| Branch: | Revision:

ffmpeg / libavcodec / eatgv.c @ 2874c81c

History | View | Annotate | Download (10.1 KB)

# Date Author Comment
2874c81c 04/03/2010 02:15 PM Stefano Sabatini

Replace all remaining occurrences of AVERROR_NOMEM with
AVERROR.

AVERROR_NOMEM is deprecated and will be dropped at the next libavutil
major bump.

Originally committed as revision 22791 to svn://svn.ffmpeg.org/ffmpeg/trunk

72415b2a 03/30/2010 11:30 PM Stefano Sabatini

Define AVMediaType enum, and use it instead of enum CodecType, which
is deprecated and will be dropped at the next major bump.

Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk

4784b092 02/26/2010 06:12 PM Vitor Sessak

Do not read beyond end of input in EA-TGV. This should avoid FATE test #362
result depending on uninitialized data.

FATE result may change for this test.

Originally committed as revision 22082 to svn://svn.ffmpeg.org/ffmpeg/trunk

8600106a 01/09/2010 03:31 AM Peter Ross

update my email address

Originally committed as revision 21106 to svn://svn.ffmpeg.org/ffmpeg/trunk

9106a698 04/13/2009 04:20 PM Stefano Sabatini

Rename bitstream.h to get_bits.h.

Originally committed as revision 18494 to svn://svn.ffmpeg.org/ffmpeg/trunk

7a00bbad 04/07/2009 03:59 PM Thilo Borgmann

Implement avcodec_decode_video2(), _audio3() and _subtitle2() which takes an
AVPacket argument rather than a const uint8_t *buf + int buf_size. This allows
passing of packet-specific flags from demuxer to decoder, such as the keyframe
flag, which appears necessary to playback corePNG P-frames....

0ffbc258 03/02/2009 05:18 AM Diego Biurrun

Change a bunch of codec long_names to be more consistent and descriptive.

Originally committed as revision 17716 to svn://svn.ffmpeg.org/ffmpeg/trunk

decae20f 02/11/2009 02:52 PM Diego Biurrun

Add av_uninit macro to variable to avoid false positive warning:
libavcodec/eatgv.c: In function ‘tgv_decode_frame’:
libavcodec/eatgv.c:66: warning: ‘offset’ may be used uninitialized in this function

Originally committed as revision 17154 to svn://svn.ffmpeg.org/ffmpeg/trunk

bad5537e 02/01/2009 02:00 AM Diego Biurrun

Use full internal pathname in doxygen @file directives.
Otherwise doxygen complains about ambiguous filenames when files exist
under the same name in different subdirectories.

Originally committed as revision 16912 to svn://svn.ffmpeg.org/ffmpeg/trunk

e29a95b1 01/14/2009 09:34 PM Aurelien Jacobs

libavutil/lzo.h is a local header

Originally committed as revision 16601 to svn://svn.ffmpeg.org/ffmpeg/trunk

cfc78718 08/06/2008 08:33 AM Peter Ross

Electronic Arts TGV decoder

Originally committed as revision 14642 to svn://svn.ffmpeg.org/ffmpeg/trunk