Statistics
| Branch: | Revision:

ffmpeg / libavcodec / put_bits.h @ 28f2db96

History | View | Annotate | Download (8.54 KB)

# Date Author Comment
28f2db96 12/01/2009 10:35 PM Baptiste Coudurier

fix typo, ALT_BITSTREAM_WRITER_LE does not exist

Originally committed as revision 20692 to svn://svn.ffmpeg.org/ffmpeg/trunk

5f1836a7 11/30/2009 11:52 PM Stefano Sabatini

Rename parameters of put_sbits() to make them consistent with those of
put_bits().

Originally committed as revision 20677 to svn://svn.ffmpeg.org/ffmpeg/trunk

587edd6a 11/29/2009 11:01 PM Stefano Sabatini

Use more consistent / meaningful parameter names for the
ff_copy_bits() function.

Originally committed as revision 20663 to svn://svn.ffmpeg.org/ffmpeg/trunk

8d872e8a 11/28/2009 10:58 AM Stefano Sabatini

Fix put_bits32() doxy.

Originally committed as revision 20639 to svn://svn.ffmpeg.org/ffmpeg/trunk

643570d6 11/28/2009 10:21 AM Stefano Sabatini

Consistently put braces for function definitions.

Originally committed as revision 20638 to svn://svn.ffmpeg.org/ffmpeg/trunk

e7422361 11/28/2009 10:17 AM Stefano Sabatini

Fix typo, "Write" -> "Writes".

Originally committed as revision 20637 to svn://svn.ffmpeg.org/ffmpeg/trunk

43d7c611 10/01/2009 03:40 PM Reimar Döffinger

put_bits can only reliably write up to 31 bit bits, above it relies on
undefined shift behaviour.
Document this, fix the assert and add a put_bits32 to handle writing 32
bits and use that where necessary.

Originally committed as revision 20124 to svn://svn.ffmpeg.org/ffmpeg/trunk

bf7e799c 06/06/2009 09:35 AM Stefano Sabatini

Remove '\p', '\c' and '\e' doxygen markup from doxy, as it should
improve plain text doxy readability.

See the thread: "[RFC] Should we use doxygen markup?".

Originally committed as revision 19122 to svn://svn.ffmpeg.org/ffmpeg/trunk

ad25b954 04/13/2009 08:44 PM Stefano Sabatini

Fix skip_put_bits() buf_ptr increment.

Originally committed as revision 18499 to svn://svn.ffmpeg.org/ffmpeg/trunk

fb53b4a0 04/13/2009 04:59 PM Stefano Sabatini

Rename pbBufPtr() to put_bits_ptr().
The new name is more readable and consistent with the FFmpeg naming
style.

Originally committed as revision 18497 to svn://svn.ffmpeg.org/ffmpeg/trunk

53bd67ec 04/12/2009 09:06 AM Stefano Sabatini

Document pbBufPtr().

Originally committed as revision 18466 to svn://svn.ffmpeg.org/ffmpeg/trunk

b2755007 04/12/2009 08:35 AM Stefano Sabatini

Split bitstream.h, put the bitstream writer stuff in the new file
put_bits.h.

Originally committed as revision 18461 to svn://svn.ffmpeg.org/ffmpeg/trunk