Move mm_support() from libavcodec to libavutil, make it a publicfunction and rename it to av_get_cpu_flags().
Originally committed as revision 25076 to svn://svn.ffmpeg.org/ffmpeg/trunk
Rename FF_MM_ symbols related to CPU features flags as AV_CPU_FLAG_symbols, and move them from libavcodec/avcodec.h to libavutil/cpu.h.
Originally committed as revision 25040 to svn://svn.ffmpeg.org/ffmpeg/trunk
Split intra prediction initialization (i.e. assigning of function pointers)into its own file, it doesn't belong in h264dsp_mmx.c (much less so indsputil_mmx.c).
Originally committed as revision 24990 to svn://svn.ffmpeg.org/ffmpeg/trunk