| Branch: | Revision:

ffmpeg / libavcodec / x86 / h264_weight.asm @ 0cc8a5d0

History | View | Annotate | Download (8.33 KB)

# Date Author Comment
b1c32fb5 09/05/2010 10:10 AM Reimar Döffinger

Use "d" suffix for general-purpose registers used with movd.
This increases compatibilty with nasm and is also more consistent,
e.g. with h264_intrapred.asm and h264_chromamc.asm that already
do it that way.

Originally committed as revision 25042 to svn://

a10a9f5c 09/01/2010 11:19 PM Eli Friedman

Fix typo in r25019.

Patch by Eli Friedman <eli.friedman at gmail dot com>.

Originally committed as revision 25022 to svn://

615da9b1 09/01/2010 09:10 PM Ronald S. Bultje

Unscrew breakage after my last commit because of symbol prefixes.

Originally committed as revision 25020 to svn://

a33a2562 09/01/2010 08:56 PM Ronald S. Bultje

Rename h264_weight_sse2.asm to h264_weight.asm; add 16x8/8x16/8x4 non-square
biweight code to sse2/ssse3; add sse2 weight code; and use that same code to
create mmx2 functions also, so that the inline asm in h264dsp_mmx.c can be
removed. OK'ed by Jason on IRC....