Fix typo in r25019.
Patch by Eli Friedman <eli.friedman at gmail dot com>.
Originally committed as revision 25022 to svn://svn.ffmpeg.org/ffmpeg/trunk
Unscrew breakage after my last commit because of symbol prefixes.
Originally committed as revision 25020 to svn://svn.ffmpeg.org/ffmpeg/trunk
Rename h264_weight_sse2.asm to h264_weight.asm; add 16x8/8x16/8x4 non-squarebiweight code to sse2/ssse3; add sse2 weight code; and use that same code tocreate mmx2 functions also, so that the inline asm in h264dsp_mmx.c can beremoved. OK'ed by Jason on IRC....