| Branch: | Revision:

ffmpeg / libavcore / imgutils.h @ 5d6e4c16

History | View | Annotate | Download (4.91 KB)

# Date Author Comment
d222e9f9 09/08/2010 11:36 PM Ramiro Polla

av_fill_image_linesizes -> av_image_fill_linesizes

Originally committed as revision 25083 to svn://

2b3cd04d 09/07/2010 09:24 PM Stefano Sabatini

Cosmetics: use plural form for *linesizes arguments of
av_image_copy(), more consistent with the rest of the API and more
semantically correct.

Originally committed as revision 25070 to svn://

34017fd9 09/07/2010 09:23 PM Stefano Sabatini

Move av_picture_data_copy() to libavcore, and rename it

Originally committed as revision 25067 to svn://

9686abb8 09/07/2010 09:23 PM Stefano Sabatini

Reimplement ff_img_copy_plane() as av_image_copy_plane() in libavcore,
and deprecate the old function.

Originally committed as revision 25064 to svn://

9b7269e3 09/07/2010 07:15 PM Stefano Sabatini

Adopt a hierarchical name scheme for the imgutils.h API. Simplify
grepping and somewhat more consistent with the scheme adopted by other
FFmpeg modules API.

Originally committed as revision 25057 to svn://

0f146263 09/06/2010 09:51 PM Stefano Sabatini

Make av_fill_image_max_pixsteps() non static non inline.

Originally committed as revision 25053 to svn://

e3443361 08/20/2010 04:52 PM Stefano Sabatini

Rename av_fill_image_max_pixstep() to av_fill_image_max_pixsteps().

The plural form is preferred as it is more consistent with the other functions:

and looks semantically more correct as it fills an array of elements....

d1a991f2 08/20/2010 04:34 PM Stefano Sabatini

Add missing period in av_fill_image_max_pixstep() doxy.

Originally committed as revision 24850 to svn://

a6ddf8bf 08/18/2010 09:02 PM Stefano Sabatini

Implement inline function av_fill_image_max_pixstep() and use it for
factorizing code.

Originally committed as revision 24827 to svn://

7906e2b9 08/12/2010 03:05 PM Stefano Sabatini

Implement av_get_image_linesize() and use it in

The new implementation is more generic, more compact and more correct.

Originally committed as revision 24786 to svn://

bf176f58 08/06/2010 09:36 AM Stefano Sabatini

Deprecate avcodec_check_dimensions() in favor of the new function
av_check_image_size() declared in libavcore/imgutils.h.

Originally committed as revision 24709 to svn://

e7bd48a6 07/29/2010 11:44 PM Stefano Sabatini

Move fill_image_linesize() and fill_image_data_ptr() from
libavcodec/imgconvert.c and make them public in libavcore/imgutils.h,
with the names av_fill_image_linesizes() and av_fill_image_pointers().

Originally committed as revision 24583 to svn://