Statistics
| Branch: | Revision:

ffmpeg / libavcore @ d370e3e9

# Date Author Comment
00e962a2 10/04/2010 01:41 PM Stefano Sabatini

Add a test for av_parse_video_rate().

Originally committed as revision 25334 to svn://svn.ffmpeg.org/ffmpeg/trunk

bc12b3b1 10/04/2010 01:41 PM Stefano Sabatini

Use av_parse_and_eval_expr() in av_parse_video_rate(), simplify.

Originally committed as revision 25333 to svn://svn.ffmpeg.org/ffmpeg/trunk

6705dd5f 10/01/2010 04:02 PM Stefano Sabatini

Fix weird indent.

Originally committed as revision 25287 to svn://svn.ffmpeg.org/ffmpeg/trunk

d222e9f9 09/08/2010 11:36 PM Ramiro Polla

av_fill_image_linesizes -> av_image_fill_linesizes

Originally committed as revision 25083 to svn://svn.ffmpeg.org/ffmpeg/trunk

6950cca9 09/07/2010 11:41 PM Stefano Sabatini

Add missing checks on invalid pixel format in
av_image_fill_linesizes/pointers.

Originally committed as revision 25072 to svn://svn.ffmpeg.org/ffmpeg/trunk

2b3cd04d 09/07/2010 09:24 PM Stefano Sabatini

Cosmetics: use plural form for *linesizes arguments of
av_image_copy(), more consistent with the rest of the API and more
semantically correct.

Originally committed as revision 25070 to svn://svn.ffmpeg.org/ffmpeg/trunk

34017fd9 09/07/2010 09:23 PM Stefano Sabatini

Move av_picture_data_copy() to libavcore, and rename it
av_image_copy().

Originally committed as revision 25067 to svn://svn.ffmpeg.org/ffmpeg/trunk

9686abb8 09/07/2010 09:23 PM Stefano Sabatini

Reimplement ff_img_copy_plane() as av_image_copy_plane() in libavcore,
and deprecate the old function.

Originally committed as revision 25064 to svn://svn.ffmpeg.org/ffmpeg/trunk

9b7269e3 09/07/2010 07:15 PM Stefano Sabatini

Adopt a hierarchical name scheme for the imgutils.h API. Simplify
grepping and somewhat more consistent with the scheme adopted by other
FFmpeg modules API.

Originally committed as revision 25057 to svn://svn.ffmpeg.org/ffmpeg/trunk

0f146263 09/06/2010 09:51 PM Stefano Sabatini

Make av_fill_image_max_pixsteps() non static non inline.

Originally committed as revision 25053 to svn://svn.ffmpeg.org/ffmpeg/trunk

625bac78 09/01/2010 02:12 AM Diego Biurrun

Use quotes instead of angle brackets for local #includes.

Originally committed as revision 25015 to svn://svn.ffmpeg.org/ffmpeg/trunk

be7110cd 08/21/2010 03:18 PM Stefano Sabatini

Cosmetics: if( -> if (.

Originally committed as revision 24859 to svn://svn.ffmpeg.org/ffmpeg/trunk

e3443361 08/20/2010 04:52 PM Stefano Sabatini

Rename av_fill_image_max_pixstep() to av_fill_image_max_pixsteps().

The plural form is preferred as it is more consistent with the other functions:
av_fill_image_linesizes()
av_fill_image_pointers()

and looks semantically more correct as it fills an array of elements....

d1a991f2 08/20/2010 04:34 PM Stefano Sabatini

Add missing period in av_fill_image_max_pixstep() doxy.

Originally committed as revision 24850 to svn://svn.ffmpeg.org/ffmpeg/trunk

a6ddf8bf 08/18/2010 09:02 PM Stefano Sabatini

Implement inline function av_fill_image_max_pixstep() and use it for
factorizing code.

Originally committed as revision 24827 to svn://svn.ffmpeg.org/ffmpeg/trunk

7906e2b9 08/12/2010 03:05 PM Stefano Sabatini

Implement av_get_image_linesize() and use it in
ff_get_plane_bytewidth().

The new implementation is more generic, more compact and more correct.

Originally committed as revision 24786 to svn://svn.ffmpeg.org/ffmpeg/trunk

899a507f 08/06/2010 09:36 AM Stefano Sabatini

Clarify av_check_image_size() log message.

Originally committed as revision 24710 to svn://svn.ffmpeg.org/ffmpeg/trunk

bf176f58 08/06/2010 09:36 AM Stefano Sabatini

Deprecate avcodec_check_dimensions() in favor of the new function
av_check_image_size() declared in libavcore/imgutils.h.

Originally committed as revision 24709 to svn://svn.ffmpeg.org/ffmpeg/trunk

ecc7bfe3 07/30/2010 08:42 AM Stefano Sabatini

Rename the av_fill_image_linesize() formal parameter linesize to
linesizes, for consistency with the function declaration.

Originally committed as revision 24591 to svn://svn.ffmpeg.org/ffmpeg/trunk

7d8d18de 07/30/2010 08:42 AM Stefano Sabatini

Reimplement av_fill_image_pointers() using the information stored in
the pixdescs.

The new implementation is more compact, and does not need to be
updated at each pixel format addition.

Originally committed as revision 24590 to svn://svn.ffmpeg.org/ffmpeg/trunk

46b1d17a 07/30/2010 08:42 AM Stefano Sabatini

Make av_fill_image_linesizes() return a meaningful error core rather
than -1.

Originally committed as revision 24589 to svn://svn.ffmpeg.org/ffmpeg/trunk

7860b436 07/30/2010 08:42 AM Stefano Sabatini

Rename av_fill_image_linesizes() internal variables max_plane_step and
max_plane_step_comp by removing the "plane_" word, and add a comment
for explaining what they represent.

Increase readability.

Originally committed as revision 24588 to svn://svn.ffmpeg.org/ffmpeg/trunk

e7bd48a6 07/29/2010 11:44 PM Stefano Sabatini

Move fill_image_linesize() and fill_image_data_ptr() from
libavcodec/imgconvert.c and make them public in libavcore/imgutils.h,
with the names av_fill_image_linesizes() and av_fill_image_pointers().

Originally committed as revision 24583 to svn://svn.ffmpeg.org/ffmpeg/trunk

54d1d1ba 07/27/2010 06:58 AM Måns Rullgård

libavcore needs libavutil

Originally committed as revision 24532 to svn://svn.ffmpeg.org/ffmpeg/trunk

ea35e3c6 07/26/2010 11:12 PM Stefano Sabatini

Avoid the use of an intermediary variable in
av_parse_video_rate(). Simplify.

Originally committed as revision 24524 to svn://svn.ffmpeg.org/ffmpeg/trunk

c90c80ac 07/26/2010 11:12 PM Stefano Sabatini

Make VideoFrameRateAbbr contain a rational rather than two ints for
num and den. Simplify.

Originally committed as revision 24523 to svn://svn.ffmpeg.org/ffmpeg/trunk

dc4a50a0 07/26/2010 11:12 PM Stefano Sabatini

Remove reference to the "frame" term in variable names. Simpler and
more consistent with the function names.

Originally committed as revision 24522 to svn://svn.ffmpeg.org/ffmpeg/trunk

afead106 07/26/2010 11:12 PM Stefano Sabatini

Make av_parse_video_size() and av_parse_video_rate() return
AVERROR rather than -1 in case of unsuccess.

Originally committed as revision 24521 to svn://svn.ffmpeg.org/ffmpeg/trunk

126b638e 07/26/2010 11:12 PM Stefano Sabatini

Deprecate av_parse_video_frame_size() and av_parse_video_frame_rate()
in favor of the newly added corresponding functions
av_parse_video_size() and av_parse_video_rate() defined in
libavcore/parseutils.h.

This change also adds a linking-time dependency of libavcodec and of...

aac6ca69 07/21/2010 06:28 PM Stefano Sabatini

Add libavcore.

The new library is meant to contain the core multimedia utilities for
FFmpeg, to make them shareable between more libav* libraries.

See thread:
Subject: [FFmpeg-devel] [RFC] New library for shared non-generic libav* utils
Date: Fri, 9 Jul 2010 01:07:40 +0200...