Prefix with "ff_" the functions:ff_avfilter_graph_check_validity()ff_avfilter_graph_config_links()ff_avfilter_graph_config_formats()
and move their declaration to internal.h. These functions are neverused in application code, so it is better to consider them internal...
Implement ff_get_ref_perms_string() and use it for tracing.
Originally committed as revision 24900 to svn://svn.ffmpeg.org/ffmpeg/trunk
Rename ff_dprintf_picref() to ff_dprintf_ref().
The function is going to be used to represent also audio data.
Originally committed as revision 24846 to svn://svn.ffmpeg.org/ffmpeg/trunk
Rename AVFilterPicRef to AVFilterBufferRef.
The struct is going to be used for storing audio buffer references aswell, and the new name is more generic.
Patch by S.N. Hemanth Meenakshisundaram smeenaks@ucsd@edu.
Originally committed as revision 24730 to svn://svn.ffmpeg.org/ffmpeg/trunk
Make avfilter.c dprintf* functions internal and declare them in aninternal.h header, so they can be easily used from other files.
Originally committed as revision 24319 to svn://svn.ffmpeg.org/ffmpeg/trunk