Use new imgutils.h API names, fix deprecation warnings.
Originally committed as revision 25058 to svn://svn.ffmpeg.org/ffmpeg/trunk
Rename av_fill_image_max_pixstep() to av_fill_image_max_pixsteps().
The plural form is preferred as it is more consistent with the other functions:av_fill_image_linesizes()av_fill_image_pointers()
and looks semantically more correct as it fills an array of elements....
Fix braino: @flip -> @file.
Originally committed as revision 24829 to svn://svn.ffmpeg.org/ffmpeg/trunk
Implement inline function av_fill_image_max_pixstep() and use it forfactorizing code.
Originally committed as revision 24827 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add hflip filter.
Originally committed as revision 24806 to svn://svn.ffmpeg.org/ffmpeg/trunk