Replace deprecated CODEC_TYPE_AUDIO and CODEC_TYPE_VIDEO with thecorresponding AVMEDIA_TYPE_* symbols.
Originally committed as revision 25201 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use new imgutils.h API names, fix deprecation warnings.
Originally committed as revision 25058 to svn://svn.ffmpeg.org/ffmpeg/trunk
Separate video specific BufferRef properties into VideoProps.
Define a new struct AVFilterBufferRefVideoProps and add a type fieldto AVFilterBufferRef.
Video specific properties in AVFilterBufferRefVideoProps are nowreferred to by *video pointer in AVFilterBufferRef....
AVFilterLink.srcpic -> AVFilterLink.src_bufAVFilterLink.cur_pic -> AVFilterLink.cur_bufAVFilterLink.outpic -> AVFilterLink.out_buf
The new names are more generic and more consistent, since the structthey contain, which was named AVFilterPicRef, has been renamed to...
Rename functions and fields:
avfilter_(un)ref_pic -> avfilter_(un)ref_bufferavfilter_copy_picref_props -> avfilter_copy_buffer_ref_propsAVFilterBufferRef.pic -> AVFilterBufferRef.buffer
They have been renamed to allow sharing with audio.
Patch by S.N. Hemanth Meenakshisundaram $smeenaks$ucsd$edu$....
Rename AVFilterPicRef to AVFilterBufferRef.
The struct is going to be used for storing audio buffer references aswell, and the new name is more generic.
Patch by S.N. Hemanth Meenakshisundaram smeenaks@ucsd@edu.
Originally committed as revision 24730 to svn://svn.ffmpeg.org/ffmpeg/trunk
Remove use of the deprecated function avcodec_check_dimensions(), useav_check_image_size() instead.
Originally committed as revision 24711 to svn://svn.ffmpeg.org/ffmpeg/trunk
Deprecate av_parse_video_frame_size() and av_parse_video_frame_rate()in favor of the newly added corresponding functionsav_parse_video_size() and av_parse_video_rate() defined inlibavcore/parseutils.h.
This change also adds a linking-time dependency of libavcodec and of...
Add color source.
Originally committed as revision 24282 to svn://svn.ffmpeg.org/ffmpeg/trunk
vf_pad: restore use of _CCIR colourspace conversion macros
Originally committed as revision 24073 to svn://svn.ffmpeg.org/ffmpeg/trunk
Move shareable draw_rectangle() and query_formats function to the topof the file, and put under #if CONFIG_PAD_FILTER the code specific tothe pad filter.
Simplify the inclusion of the color source.
Originally committed as revision 24067 to svn://svn.ffmpeg.org/ffmpeg/trunk
Factorize out some code and implement the fill_line_with_color()function. Allow to share code with the pending color source.
Originally committed as revision 24066 to svn://svn.ffmpeg.org/ffmpeg/trunk
Enhance pad filter command-line description.
Based on a patch by John Calcote $email@example.com.
Originally committed as revision 24030 to svn://svn.ffmpeg.org/ffmpeg/trunk
Move colorspace.h from libavcodec to libavutil.Avoid a compile-time dependency of the pad filter on libavcodec.
Originally committed as revision 23940 to svn://svn.ffmpeg.org/ffmpeg/trunk
Set pad description with NULL_IF_CONFIG_SMALL(), consistent with theother filters.
Originally committed as revision 23923 to svn://svn.ffmpeg.org/ffmpeg/trunk
Improve description for the pad filter.
Originally committed as revision 23922 to svn://svn.ffmpeg.org/ffmpeg/trunk
Remove the name of the file from the @file doxy, it is unnecessary andinconsistent with the other files.
Originally committed as revision 23122 to svn://svn.ffmpeg.org/ffmpeg/trunk
Make the init and config_filter callbacks of the pad filter returnAVERROR rather than -1 in case of invalid parameters.
Originally committed as revision 23121 to svn://svn.ffmpeg.org/ffmpeg/trunk
silence gcc warning about potential uninitialized usage
Originally committed as revision 23093 to svn://svn.ffmpeg.org/ffmpeg/trunk
vf_pad: fix mixed code and declarations
Originally committed as revision 23054 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add pad filter.
Originally committed as revision 23046 to svn://svn.ffmpeg.org/ffmpeg/trunk