In libavfilter, use consistently "Copyright (c)" in the licenseheaders.
Originally committed as revision 25838 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add missing uses of NULL_IF_CONFIG_SMALL for the filters descriptions.
Originally committed as revision 25182 to svn://svn.ffmpeg.org/ffmpeg/trunk
AVFilterLink.srcpic -> AVFilterLink.src_bufAVFilterLink.cur_pic -> AVFilterLink.cur_bufAVFilterLink.outpic -> AVFilterLink.out_buf
The new names are more generic and more consistent, since the structthey contain, which was named AVFilterPicRef, has been renamed to...
Rename functions and fields:
avfilter_(un)ref_pic -> avfilter_(un)ref_bufferavfilter_copy_picref_props -> avfilter_copy_buffer_ref_propsAVFilterBufferRef.pic -> AVFilterBufferRef.buffer
They have been renamed to allow sharing with audio.
Patch by S.N. Hemanth Meenakshisundaram $smeenaks$ucsd$edu$....
Rename AVFilterPicRef to AVFilterBufferRef.
The struct is going to be used for storing audio buffer references aswell, and the new name is more generic.
Patch by S.N. Hemanth Meenakshisundaram smeenaks@ucsd@edu.
Originally committed as revision 24730 to svn://svn.ffmpeg.org/ffmpeg/trunk
Reindent after r24101.
Originally committed as revision 24126 to svn://svn.ffmpeg.org/ffmpeg/trunk
Rename read/write_line() to av_read/write_image_line().
The old names were not av_ prefixed, and they were causing linkingfailure on many platforms. The new names are also more descriptive.
Patch by Stefano Sabatini.
Originally committed as revision 24101 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add pixdesctest filter and corresponding test.
Originally committed as revision 24092 to svn://svn.ffmpeg.org/ffmpeg/trunk