Add missing uses of NULL_IF_CONFIG_SMALL for the filters descriptions.
Originally committed as revision 25182 to svn://svn.ffmpeg.org/ffmpeg/trunk
100L, fix vf_scale, since copy_ref_props now copy w and h, we must update them
Originally committed as revision 24781 to svn://svn.ffmpeg.org/ffmpeg/trunk
Separate video specific BufferRef properties into VideoProps.
Define a new struct AVFilterBufferRefVideoProps and add a type fieldto AVFilterBufferRef.
Video specific properties in AVFilterBufferRefVideoProps are nowreferred to by *video pointer in AVFilterBufferRef....
AVFilterLink.srcpic -> AVFilterLink.src_bufAVFilterLink.cur_pic -> AVFilterLink.cur_bufAVFilterLink.outpic -> AVFilterLink.out_buf
The new names are more generic and more consistent, since the structthey contain, which was named AVFilterPicRef, has been renamed to...
Rename functions and fields:
avfilter_(un)ref_pic -> avfilter_(un)ref_bufferavfilter_copy_picref_props -> avfilter_copy_buffer_ref_propsAVFilterBufferRef.pic -> AVFilterBufferRef.buffer
They have been renamed to allow sharing with audio.
Patch by S.N. Hemanth Meenakshisundaram $smeenaks$ucsd$edu$....
Rename AVFilterPicRef to AVFilterBufferRef.
The struct is going to be used for storing audio buffer references aswell, and the new name is more generic.
Patch by S.N. Hemanth Meenakshisundaram smeenaks@ucsd@edu.
Originally committed as revision 24730 to svn://svn.ffmpeg.org/ffmpeg/trunk
Generalize pixel format enum fields to int formats.
This is needed to make the libavfilter framework work with audiofilters.
In particular add a type field to AVFilterLink, change the field types:enum PixelFormat format -> int format in AVFilterBuffer...
Use avfilter_copy_picref_props() along lavfi.
Originally committed as revision 24196 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add a const declaration, fixing a warning
Patch by Eli Friedman, eli dot friedman at gmail
Originally committed as revision 23830 to svn://svn.ffmpeg.org/ffmpeg/trunk
Prefix value for flags with "0x", to make it clear that it is anhexadecimal value.
Originally committed as revision 23262 to svn://svn.ffmpeg.org/ffmpeg/trunk
Make config_props() show conversion information before to create theswscale context.
This makes eventual warnings issued in case of swscale contextcreation failure to be shown after the conversion information ratherthan before, which is slightly less confusing....
Log input size, input format and swscale flags used for conversion inconfig_props().
Useful for debugging.
Originally committed as revision 23055 to svn://svn.ffmpeg.org/ffmpeg/trunk
c99 sucks. Replacing scanf("%i") by strtoul()
Originally committed as revision 23053 to svn://svn.ffmpeg.org/ffmpeg/trunk
Try to keep track of interlaced and top field first.
Originally committed as revision 23044 to svn://svn.ffmpeg.org/ffmpeg/trunk
Support setting flags for sws.
Originally committed as revision 23041 to svn://svn.ffmpeg.org/ffmpeg/trunk
Remove explicit filename from Doxygen @file commands.
Passing an explicit filename to this command is only necessary if thedocumentation in the @file block refers to a file different from theone the block resides in.
Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
Define AVMediaType enum, and use it instead of enum CodecType, whichis deprecated and will be dropped at the next major bump.
Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
Make the scale filter pass the pkt.pos information to the outputpicref.
Originally committed as revision 22509 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use pixel format descriptors to check if the input format is paletted.
Originally committed as revision 21597 to svn://svn.ffmpeg.org/ffmpeg/trunk
Avoid usage of avcodec_get_pix_fmt_name() andavcodec_get_chroma_sub_sample(), directly accessav_pix_fmt_descriptors instead.
Remove some of the dependancies of lavfi on lavc.
Originally committed as revision 21575 to svn://svn.ffmpeg.org/ffmpeg/trunk
Make the scale filter set in the input and output links only the respective pixel formats effectively supported by libswscale.
Originally committed as revision 21105 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add a slice_dir parameter to avfilter_draw_slice().
Avoid the need to implement slice direction detection code, thusreducing code duplication.
See the thread:"[FFmpeg-devel] [PATCH] Add a slice_dir parameter to avfilter_start_frame()".
Originally committed as revision 20734 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use the correct chroma values for the data array used indraw_slice().
The chroma values to use are supposed to be those of the input format,not that of the output format, the latter case was causing crashes andchroma issues.
Originally committed as revision 20660 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use a valid log context for av_log().
Originally committed as revision 20659 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add scale filter.
Originally committed as revision 20519 to svn://svn.ffmpeg.org/ffmpeg/trunk