Remove explicit filename from Doxygen @file commands.
Passing an explicit filename to this command is only necessary if thedocumentation in the @file block refers to a file different from theone the block resides in.
Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
Define AVMediaType enum, and use it instead of enum CodecType, whichis deprecated and will be dropped at the next major bump.
Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use the new null callbacks to simplify filters and reduce duplicated code.
Originally committed as revision 22595 to svn://svn.ffmpeg.org/ffmpeg/trunk
Extend the slice filter to make it issue slice height values randomlychoosen between 8 and 32 when the supplied parameter is the string"random".
This is useful for testing the slice support, but it is not supposedto be used for other purposes and this interface may change in the...
Avoid usage of avcodec_get_pix_fmt_name() andavcodec_get_chroma_sub_sample(), directly accessav_pix_fmt_descriptors instead.
Remove some of the dependancies of lavfi on lavc.
Originally committed as revision 21575 to svn://svn.ffmpeg.org/ffmpeg/trunk
Reindent after the last commit.
Originally committed as revision 20755 to svn://svn.ffmpeg.org/ffmpeg/trunk
Fix slicify when the slice_direction is negative, make it send slicesfrom the bottom to the top one.
Originally committed as revision 20754 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add a slice_dir parameter to avfilter_draw_slice().
Avoid the need to implement slice direction detection code, thusreducing code duplication.
See the thread:"[FFmpeg-devel] [PATCH] Add a slice_dir parameter to avfilter_start_frame()".
Originally committed as revision 20734 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add slicify video filter.
Originally committed as revision 20445 to svn://svn.ffmpeg.org/ffmpeg/trunk