Replace FFmpeg with Libav in licence headers
Signed-off-by: Mans Rullgard <email@example.com>
lavf: replace avio_seek(SEEK_CUR) with avio_skip where it makes sense
Signed-off-by: Ronald S. Bultje <firstname.lastname@example.org>
avio: deprecate url_feof
AVIOContext.eof_reached should be used directly instead.
avio: add avio_tell macro as a replacement for url_ftell
avio: avio_ prefix for url_fseek
avio: avio_ prefixes for get_* functions
In the name of consistency:get_byte -> avio_r8get_<type> -> avio_r<type>get_buffer -> avio_read
get_partial_buffer will be made private later
get_strz is left out becase I want to change it later to return...
avio: rename ByteIOContext to AVIOContext.
Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.
This also lists the objects from those two libraries as internal (by addingthe ff_ prefix) so that they can then be hidden via linker scripts.
Remove explicit filename from Doxygen @file commands.
Passing an explicit filename to this command is only necessary if thedocumentation in the @file block refers to a file different from theone the block resides in.
Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
Define AVMediaType enum, and use it instead of enum CodecType, whichis deprecated and will be dropped at the next major bump.
Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use full internal pathname in doxygen @file directives.Otherwise doxygen complains about ambiguous filenames when files existunder the same name in different subdirectories.
Originally committed as revision 16912 to svn://svn.ffmpeg.org/ffmpeg/trunk
Fix build: Add intreadwrite.h and bswap.h #includes where necessary.
Originally committed as revision 16556 to svn://svn.ffmpeg.org/ffmpeg/trunk
Bump Major version, this commit is almost just renaming bits_per_sample tobits_per_coded_sample but that cannot be done seperately.Patch by Luca AbeniAlso reset the minor version and fix the forgotton change to libfaad.Note: The API/ABI should not be considered stable yet, there still may...
Make long_names in lavf/lavdev optional depending on CONFIG_SMALL.patch by Stefano Sabatini, stefano.sabatini-lala poste.italong with some spelling/consistency fixes for the long names by me
Originally committed as revision 13649 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use full path for #includes from another directory.
Originally committed as revision 13098 to svn://svn.ffmpeg.org/ffmpeg/trunk
Remove unnecessary parentheses from return calls.
Originally committed as revision 13069 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use dynamically allocated ByteIOContext in AVFormatContext
patch by: Björn Axelsson, bjorn d axelsson a intinor d sethread: [PATCH] Remove static ByteIOContexts, 06 nov 2007
Originally committed as revision 11071 to svn://svn.ffmpeg.org/ffmpeg/trunk
Replace all occurrences of AVERROR_IO with AVERROR.
Originally committed as revision 9760 to svn://svn.ffmpeg.org/ffmpeg/trunk
Replace all occurrences of AVERROR_NOMEM with AVERROR.
Originally committed as revision 9759 to svn://svn.ffmpeg.org/ffmpeg/trunk
bethsoftvid: use correct type for size passed to av_fast_realloc()
Originally committed as revision 9538 to svn://svn.ffmpeg.org/ffmpeg/trunk
allocate 32 extra bytes at the end of the probe buffer and remove most probe buf_size checks
Originally committed as revision 8677 to svn://svn.ffmpeg.org/ffmpeg/trunk
s/rle_num_bytes/code/shorter and correcter (its not the number of anything)
Originally committed as revision 8673 to svn://svn.ffmpeg.org/ffmpeg/trunk
Originally committed as revision 8669 to svn://svn.ffmpeg.org/ffmpeg/trunk
conform to spec
Originally committed as revision 8668 to svn://svn.ffmpeg.org/ffmpeg/trunk
use shorter names for the block type enum
Originally committed as revision 8664 to svn://svn.ffmpeg.org/ffmpeg/trunk
code claims to use 32bit timestamp, lets make it also use that
Originally committed as revision 8662 to svn://svn.ffmpeg.org/ffmpeg/trunk
remove redundant comments
Originally committed as revision 8661 to svn://svn.ffmpeg.org/ffmpeg/trunk
remove inappropriate debuging av_log() alternatively they could be changed to dprintf()
Originally committed as revision 8660 to svn://svn.ffmpeg.org/ffmpeg/trunk
memleak (seems ive missed that under the obfuscated indention)
Originally committed as revision 8659 to svn://svn.ffmpeg.org/ffmpeg/trunk
sane indention (no more 3 statements on one line...)
Originally committed as revision 8658 to svn://svn.ffmpeg.org/ffmpeg/trunk
Bethsoft VID demuxer and video decoderpatch by Nicholas Tung, ntung ntung com
Originally committed as revision 8649 to svn://svn.ffmpeg.org/ffmpeg/trunk