avio: introduce an AVIOContext.seekable field
Use it instead of url_is_streamed and AVIOContext.is_streamed.
Replace FFmpeg with Libav in licence headers
Signed-off-by: Mans Rullgard <firstname.lastname@example.org>
lavf: replace avio_seek(SEEK_CUR) with avio_skip where it makes sense
Signed-off-by: Ronald S. Bultje <email@example.com>
avio: deprecate url_feof
AVIOContext.eof_reached should be used directly instead.
avio: avio_ prefix for url_fsize
avio: add avio_tell macro as a replacement for url_ftell
lavf: deprecate get_strz() in favor of avio_get_str
lavf: replace all uses of url_fskip with avio_seek
avio: avio_ prefix for url_fseek
avio: avio_ prefixes for get_* functions
In the name of consistency:get_byte -> avio_r8get_<type> -> avio_r<type>get_buffer -> avio_read
get_partial_buffer will be made private later
get_strz is left out becase I want to change it later to return...
avio: rename ByteIOContext to AVIOContext.
Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.
This also lists the objects from those two libraries as internal (by addingthe ff_ prefix) so that they can then be hidden via linker scripts.
cafdec: Handle ALAC extradata.
This fixes roundup issue 2284.
Originally committed as revision 25430 to svn://svn.ffmpeg.org/ffmpeg/trunk
Mark av_metadata_set() as deprecated, and use av_metadata_set2()in its place.
av_metadata_set() is going to be dropped at the next major bump.
Originally committed as revision 22961 to svn://svn.ffmpeg.org/ffmpeg/trunk
Remove explicit filename from Doxygen @file commands.
Passing an explicit filename to this command is only necessary if thedocumentation in the @file block refers to a file different from theone the block resides in.
Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
Replace all remaining occurrences of AVERROR_NOMEM withAVERROR.
AVERROR_NOMEM is deprecated and will be dropped at the next libavutilmajor bump.
Originally committed as revision 22791 to svn://svn.ffmpeg.org/ffmpeg/trunk
Define AVMediaType enum, and use it instead of enum CodecType, whichis deprecated and will be dropped at the next major bump.
Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
Replace all the occurrences of AVERROR_EIO with AVERROR, and markAVERROR_EIO for deletion at the next major bump.
Originally committed as revision 22513 to svn://svn.ffmpeg.org/ffmpeg/trunk
Core Audio Format demuxer
Originally committed as revision 19879 to svn://svn.ffmpeg.org/ffmpeg/trunk