lavf: replace all uses of url_fskip with avio_seek
Signed-off-by: Ronald S. Bultje <email@example.com>
avio: avio_ prefix for url_fseek
avio: avio_ prefixes for get_* functions
In the name of consistency:get_byte -> avio_r8get_<type> -> avio_r<type>get_buffer -> avio_read
get_partial_buffer will be made private later
get_strz is left out becase I want to change it later to return...
avio: rename ByteIOContext to AVIOContext.
Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.
This also lists the objects from those two libraries as internal (by addingthe ff_ prefix) so that they can then be hidden via linker scripts.
Define AVMediaType enum, and use it instead of enum CodecType, whichis deprecated and will be dropped at the next major bump.
Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
Improve dxa probe by checking the values for width and height are reasonable.
Originally committed as revision 19897 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add ff_ prefixes to exported symbols in libavformat/riff.h.patch by Daniel Verkamp, aniel drv nu
Originally committed as revision 19254 to svn://svn.ffmpeg.org/ffmpeg/trunk
cosmetics: Remove pointless period after copyright statement non-sentences.
Originally committed as revision 16684 to svn://svn.ffmpeg.org/ffmpeg/trunk
Fix build: Add intreadwrite.h and bswap.h #includes where necessary.
Originally committed as revision 16556 to svn://svn.ffmpeg.org/ffmpeg/trunk
Make long_names in lavf/lavdev optional depending on CONFIG_SMALL.patch by Stefano Sabatini, stefano.sabatini-lala poste.italong with some spelling/consistency fixes for the long names by me
Originally committed as revision 13649 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use dynamically allocated ByteIOContext in AVFormatContext
patch by: Björn Axelsson, bjorn d axelsson a intinor d sethread: [PATCH] Remove static ByteIOContexts, 06 nov 2007
Originally committed as revision 11071 to svn://svn.ffmpeg.org/ffmpeg/trunk
Replace all occurrences of AVERROR_IO with AVERROR.
Originally committed as revision 9760 to svn://svn.ffmpeg.org/ffmpeg/trunk
Replace all occurrences of AVERROR_NOMEM with AVERROR.
Originally committed as revision 9759 to svn://svn.ffmpeg.org/ffmpeg/trunk
allocate 32 extra bytes at the end of the probe buffer and remove most probe buf_size checks
Originally committed as revision 8677 to svn://svn.ffmpeg.org/ffmpeg/trunk
DXA demuxer and decoder
Originally committed as revision 8405 to svn://svn.ffmpeg.org/ffmpeg/trunk