lavf: replace avio_seek(SEEK_CUR) with avio_skip where it makes sense
Signed-off-by: Ronald S. Bultje <email@example.com>
avio: deprecate url_feof
AVIOContext.eof_reached should be used directly instead.
avio: add avio_tell macro as a replacement for url_ftell
avio: avio_ prefix for url_fseek
avio: avio_ prefixes for get_* functions
In the name of consistency:get_byte -> avio_r8get_<type> -> avio_r<type>get_buffer -> avio_read
get_partial_buffer will be made private later
get_strz is left out becase I want to change it later to return...
avio: rename ByteIOContext to AVIOContext.
Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.
This also lists the objects from those two libraries as internal (by addingthe ff_ prefix) so that they can then be hidden via linker scripts.
rename idroq.c to idroqdec.c
Originally committed as revision 24969 to svn://svn.ffmpeg.org/ffmpeg/trunk