lavf: replace all uses of url_fskip with avio_seek
Signed-off-by: Ronald S. Bultje <firstname.lastname@example.org>
avio: avio_ prefix for url_fseek
avio: avio_ prefixes for get_* functions
In the name of consistency:get_byte -> avio_r8get_<type> -> avio_r<type>get_buffer -> avio_read
get_partial_buffer will be made private later
get_strz is left out becase I want to change it later to return...
avio: rename ByteIOContext to AVIOContext.
Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.
This also lists the objects from those two libraries as internal (by addingthe ff_ prefix) so that they can then be hidden via linker scripts.
Make ff_cmap_read_palette static to libavcodec/iff.c. Delete iff.h.
The iff.h header only declared one function that is now static, thelibavformat/iff.c source file wasn't using it before. Drop the fileentirely.
Signed-off-by: Mans Rullgard <email@example.com>
remove redundant text and whitespaces from iff demuxer av_log() statements
Originally committed as revision 24246 to svn://svn.ffmpeg.org/ffmpeg/trunk
Reindent after r23112.
Patch by Sebastian Vater <cdgs basty googlemail com>.
Originally committed as revision 23113 to svn://svn.ffmpeg.org/ffmpeg/trunk
Move handling of paletted data to the IFF demuxer. This allows futurehandling of things such as masking/EHB/HAM for this type of data.
Originally committed as revision 23112 to svn://svn.ffmpeg.org/ffmpeg/trunk
Replace usage of s->streams0->* with st->*, which is shorter.
Originally committed as revision 23069 to svn://svn.ffmpeg.org/ffmpeg/trunk
Parse IFF metadata.
Patch by Sebastian Vater, cdgs D basty A googlemail
Originally committed as revision 23024 to svn://svn.ffmpeg.org/ffmpeg/trunk
Reindent after rr22977.
Patch by Sebastian Vater <cdgs.basty googlemail com>.
Originally committed as revision 22978 to svn://svn.ffmpeg.org/ffmpeg/trunk
Make the IFF demuxer a little more standards-compliant, e.g. respect the sizefields of common media header chunks (these can have different sizes dependingon the type of IFF file you read), better handle odd sizes (like RIFF, everyfield is padded to word) and handle headerchunks after the BODY chunk....
Reindent / reformat some code with broken indenting.
Patch by Sebastian Vater <cdgs DOT basty googlemail com>.
Originally committed as revision 22924 to svn://svn.ffmpeg.org/ffmpeg/trunk
Remove explicit filename from Doxygen @file commands.
Passing an explicit filename to this command is only necessary if thedocumentation in the @file block refers to a file different from theone the block resides in.
Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
Replace all occurences of PKT_FLAG_KEY with AV_PKT_FLAG_KEY.
Patch by Jean-Daniel Dupas, devlists shadowlab org
Originally committed as revision 22744 to svn://svn.ffmpeg.org/ffmpeg/trunk
Define AVMediaType enum, and use it instead of enum CodecType, whichis deprecated and will be dropped at the next major bump.
Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
IFF: move ff_cmap_read_palette() prototype to a header file
Originally committed as revision 22307 to svn://svn.ffmpeg.org/ffmpeg/trunk
Support IFF ANNO (annotation) chunk type
Originally committed as revision 21847 to svn://svn.ffmpeg.org/ffmpeg/trunk
Originally committed as revision 21624 to svn://svn.ffmpeg.org/ffmpeg/trunk
Extend IFF demuxer to parse PBM/ILBM bitmap chunks
Originally committed as revision 21623 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use full internal pathname in doxygen @file directives.Otherwise doxygen complains about ambiguous filenames when files existunder the same name in different subdirectories.
Originally committed as revision 16912 to svn://svn.ffmpeg.org/ffmpeg/trunk
Fix build: Add intreadwrite.h and bswap.h #includes where necessary.
Originally committed as revision 16556 to svn://svn.ffmpeg.org/ffmpeg/trunk
Avoid _t in identifier names, _t is reserved by POSIX.patch by Jai Menon, jmenon86 gmail com
Originally committed as revision 16098 to svn://svn.ffmpeg.org/ffmpeg/trunk
Bump Major version, this commit is almost just renaming bits_per_sample tobits_per_coded_sample but that cannot be done seperately.Patch by Luca AbeniAlso reset the minor version and fix the forgotton change to libfaad.Note: The API/ABI should not be considered stable yet, there still may...
Make long_names in lavf/lavdev optional depending on CONFIG_SMALL.patch by Stefano Sabatini, stefano.sabatini-lala poste.italong with some spelling/consistency fixes for the long names by me
Originally committed as revision 13649 to svn://svn.ffmpeg.org/ffmpeg/trunk
IFF stereo support
Patch by Jai Menon ( realityman gmx net )
Originally committed as revision 13097 to svn://svn.ffmpeg.org/ffmpeg/trunk
Remove unused variable.
Originally committed as revision 12670 to svn://svn.ffmpeg.org/ffmpeg/trunk
minor typo fixes
Originally committed as revision 12658 to svn://svn.ffmpeg.org/ffmpeg/trunk
Patch by Jai Menon (realityman <at> gmx.net)
Originally committed as revision 12633 to svn://svn.ffmpeg.org/ffmpeg/trunk