Statistics
| Branch: | Revision:

ffmpeg / libavformat / internal.h @ da9e6c42

History | View | Annotate | Download (6.58 KB)

# Date Author Comment
80b39e1c 05/22/2010 04:01 PM Francesco Lavra

Move AVCodecTag from riff.h into internal.h.

Patch by Francesco Lavra, francescolavra interfree it

Originally committed as revision 23250 to svn://svn.ffmpeg.org/ffmpeg/trunk

9a761250 05/21/2010 07:07 AM Martin Storsjö

Add a libavformat internal function ff_write_chained

Originally committed as revision 23207 to svn://svn.ffmpeg.org/ffmpeg/trunk

0341b699 05/18/2010 07:32 PM Martin Storsjö

Make ff_sdp_write_media a lavf-internal function

This is in preparation for RTP hinting in the MOV muxer, where
it needs to be able to create SDP fragments for each media stream.

Originally committed as revision 23160 to svn://svn.ffmpeg.org/ffmpeg/trunk

9a2cb05f 04/11/2010 09:44 PM Stefano Sabatini

Move the internal function declarations in avformat.h to internal.h.

Originally committed as revision 22843 to svn://svn.ffmpeg.org/ffmpeg/trunk

ddbeb954 03/25/2010 07:13 AM Martin Storsjö

Add a lowercase parameter to ff_data_to_hex

Originally committed as revision 22665 to svn://svn.ffmpeg.org/ffmpeg/trunk

972ffe62 03/15/2010 11:15 PM Aurelien Jacobs

rename av_read_frame_flush to ff_read_frame_flush
it is an internal function, not part of public API

Originally committed as revision 22562 to svn://svn.ffmpeg.org/ffmpeg/trunk

588af13f 03/15/2010 11:14 PM Aurelien Jacobs

rename av_program_add_stream_index to ff_program_add_stream_index
it is an internal function, not part of public API

Originally committed as revision 22561 to svn://svn.ffmpeg.org/ffmpeg/trunk

2dad0dce 03/15/2010 10:36 AM Martin Storsjö

Move the NTP offset definitions to internal.h

Originally committed as revision 22542 to svn://svn.ffmpeg.org/ffmpeg/trunk

e4a9e3cc 03/14/2010 11:59 PM Aurelien Jacobs

move ff_url_split() and ff_url_join() declarations to internal.h
those functions are not part of the public API

Originally committed as revision 22534 to svn://svn.ffmpeg.org/ffmpeg/trunk

eadd495d 03/14/2010 10:40 PM Micah F. Galizia

Move the probe loop from av_open_input_file() into its own method
av_probe_input_buffer() so that it can be reused. Here are a few
differences to the original way things were probed:

- maximum probe buffer size can be specified as a parameter.

- offset within the stream to probe from can be specified as a parameter....

594a9aeb 03/10/2010 10:21 PM Martin Storsjö

Make the ntp_time function available to other parts of libavformat, as ff_ntp_time

Originally committed as revision 22438 to svn://svn.ffmpeg.org/ffmpeg/trunk

f19341e1 03/08/2010 03:46 AM Måns Rullgård

Revert "Move the probe loop from av_open_input_file() into its own method"

This reverts r22296. This change made some files to fail to open.
The patch submitter has promised to investigate next week.

Originally committed as revision 22315 to svn://svn.ffmpeg.org/ffmpeg/trunk

4245c6ec 03/07/2010 10:42 PM Micah F. Galizia

Move the probe loop from av_open_input_file() into its own method
av_probe_input_buffer() so that it can be reused. Here are a few
differences to the original way things were probed:

- maximum probe buffer size can be specified as a parameter.

- offset within the stream to probe from can be specified as a parameter....

e16c73e6 03/06/2010 11:19 PM Måns Rullgård

Move av_read_frame_flush() prototype to lavf/internal.h

Originally committed as revision 22268 to svn://svn.ffmpeg.org/ffmpeg/trunk

949cd978 02/10/2009 12:27 AM Aurelien Jacobs

remove now useless av_set_program_name() function

Originally committed as revision 17113 to svn://svn.ffmpeg.org/ffmpeg/trunk

7a094c6a 02/09/2009 12:18 AM Baptiste Coudurier

remove no more needed comment, declaration is in internal header

Originally committed as revision 17086 to svn://svn.ffmpeg.org/ffmpeg/trunk

1cc65cec 02/08/2009 09:14 PM Baptiste Coudurier

Move declaration of ff_interleave_add_packet to internal.h.
It is an internal function and should not be in an installed header.

Originally committed as revision 17070 to svn://svn.ffmpeg.org/ffmpeg/trunk

bad40637 12/03/2008 04:47 PM Diego Biurrun

Move declaration of av_set_program_name and av_program_add_stream_index
to a more sensible place.

Originally committed as revision 15991 to svn://svn.ffmpeg.org/ffmpeg/trunk

95137bbb 10/04/2008 11:20 AM Diego Biurrun

Fix 'make checkheaders', based on a patch by Diego Pettenò, flameeyes gmail com.

Originally committed as revision 15552 to svn://svn.ffmpeg.org/ffmpeg/trunk

98790382 08/31/2008 07:39 AM Stefano Sabatini

Globally rename the header inclusion guard names.

Consistently apply this rule: the guard name is obtained from the
filename by stripping the leading "lib", converting '/' and '.' to
'_' and uppercasing the resulting name. Guard names in the root
directory have to be prefixed by "FFMPEG_"....

f1c80e35 08/27/2008 11:43 PM Ronald S. Bultje

Export data_to_hex() as private API in lavf, rename to ff_data_to_hex() and
move it from sdp.c into utils.c. Also add new header internal.h specifically
for lavf-specific internal API. See discussion in "Realmedia patch" thread
on mailinglist.

Originally committed as revision 15002 to svn://svn.ffmpeg.org/ffmpeg/trunk