avio: avio_ prefixes for get_* functions
In the name of consistency:get_byte -> avio_r8get_<type> -> avio_r<type>get_buffer -> avio_read
get_partial_buffer will be made private later
get_strz is left out becase I want to change it later to return...
avio: rename ByteIOContext to AVIOContext.
Signed-off-by: Ronald S. Bultje <firstname.lastname@example.org>
Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.
This also lists the objects from those two libraries as internal (by addingthe ff_ prefix) so that they can then be hidden via linker scripts.
Replace all remaining occurrences of AVERROR_NOMEM withAVERROR.
AVERROR_NOMEM is deprecated and will be dropped at the next libavutilmajor bump.
Originally committed as revision 22791 to svn://svn.ffmpeg.org/ffmpeg/trunk
Replace all occurences of PKT_FLAG_KEY with AV_PKT_FLAG_KEY.
Patch by Jean-Daniel Dupas, devlists shadowlab org
Originally committed as revision 22744 to svn://svn.ffmpeg.org/ffmpeg/trunk
Define AVMediaType enum, and use it instead of enum CodecType, whichis deprecated and will be dropped at the next major bump.
Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
Make long_names in lavf/lavdev optional depending on CONFIG_SMALL.patch by Stefano Sabatini, stefano.sabatini-lala poste.italong with some spelling/consistency fixes for the long names by me
Originally committed as revision 13649 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use full path for #includes from another directory.
Originally committed as revision 13098 to svn://svn.ffmpeg.org/ffmpeg/trunk
MSN TCP Webcam stream demuxer.
Originally committed as revision 12492 to svn://svn.ffmpeg.org/ffmpeg/trunk