Replace FFmpeg with Libav in licence headers
Signed-off-by: Mans Rullgard <email@example.com>
avio: rename ByteIOContext to AVIOContext.
Signed-off-by: Ronald S. Bultje <firstname.lastname@example.org>
Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.
This also lists the objects from those two libraries as internal (by addingthe ff_ prefix) so that they can then be hidden via linker scripts.
Move rm_codec_tags to rm.c so muxer/demuxer can share it.
Patch by Francesco Lavra <francescolavra interfree it>.
Originally committed as revision 23360 to svn://svn.ffmpeg.org/ffmpeg/trunk
Replace @returns by @return.
Originally committed as revision 22729 to svn://svn.ffmpeg.org/ffmpeg/trunk
export rm_reorder_sipr_data() for future use by matroska demuxer
Originally committed as revision 22491 to svn://svn.ffmpeg.org/ffmpeg/trunk
export sipr_subpk_size for future use by matroska demuxer
Originally committed as revision 22490 to svn://svn.ffmpeg.org/ffmpeg/trunk
ff_rm_metadata is const.
Originally committed as revision 19786 to svn://svn.ffmpeg.org/ffmpeg/trunk
Don't use a pointer-to-flags/timestamp in ff_rm_parse_packet(); the functionused to return packet data, which might update the flags/timestamp to beused for the next packet data returned by the demuxer. However, that wasseparated out into a new function, and the flags/timestamp are thus never...
Remove '\p', '\c' and '\e' doxygen markup from doxy, as it shouldimprove plain text doxy readability.
See the thread: "[RFC] Should we use doxygen markup?".
Originally committed as revision 19122 to svn://svn.ffmpeg.org/ffmpeg/trunk
Remove packet returning in ff_rm_parse_packet() if we're using the packetcache, since this can already be accessed through ff_rm_retrieve_cache().See "[PATCH] rmdec.c: remove cache access duplication" thread.
Originally committed as revision 18009 to svn://svn.ffmpeg.org/ffmpeg/trunk
use new metadata API in rm (de)muxer
Originally committed as revision 17396 to svn://svn.ffmpeg.org/ffmpeg/trunk
cosmetics: Remove pointless period after copyright statement non-sentences.
Originally committed as revision 16684 to svn://svn.ffmpeg.org/ffmpeg/trunk
Reindent after r16368.
Originally committed as revision 16369 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add audio_pkt_cnt return value to ff_rm_retrieve_cache(). See discussion in"[PATCH] oops I broke rdt.c" mailinglist thread.
Originally committed as revision 16368 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add RMStream object as function argument to public functions so that non-.rmAVStreams can be used to call these public rmdec.c functions as well, as isthe case for RDT/RTSP streams. See mailinglist discussion in "[PATCH] rdt.c:don't reuse the same AVStream in both RTSP and RM demuxer" thread....
Implement RMStream stream-specific private data object in the RM demuxer.This allows multiple video or audio streams per .rm file. See mailinglistthread "[PATCH] rmdec.c: implement RMVideo/AudioStream".
Originally committed as revision 16365 to svn://svn.ffmpeg.org/ffmpeg/trunk
Split RMContext into RMDemux/MuxContext and make them private in rmdec/enc.c.Reason for this is that there are no shared entries in the demuxer/muxercontext, making it a mystery as to why it was shared between the two. See"[PATCH] clean rmdemux/muxcontext" patch on mailinglist....
Don't access RMContext directly in rdt.c. Rather, use the return value offf_rm_parse_packet() to indicate whether more audio packets are availablein the demuxer from the last RM frame, and save that in the RDT parsingcontext. See patch/discussion in "[PATCH] rdt.c: don't access RMContext"...
Add ByteIOContext argument to public ff_rm_* functions so that we canspecify the data source as function argument instead of in s->pb beforecalling the function. Discussed in ML thread "[PATCH] fix small memleakin rdt.c".
Originally committed as revision 15849 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add dynamic payload handlers to rdt.c. These follow the same API as the onesin rtpdec.c, so that they can be shared and used in the same way in rtsp.c.The handlers, since they are specific for RDT, are registered in rdt.c anda new registration function is thus called from allformats.c....
Use chunk-size in function calling mdpr_read_codecdata() rather than in thefunction itself. This way, old-style (.ra4) RTSP/RDT OpaqueData chunks canbe parsed using this function as well (they don't have the size bits). Seediscussion on ML in "[PATCH] rmdec.c - small read_mdpr_codecdata() API...
Globally rename the header inclusion guard names.
Consistently apply this rule: the guard name is obtained from thefilename by stripping the leading "lib", converting '/' and '.' to'_' and uppercasing the resulting name. Guard names in the rootdirectory have to be prefixed by "FFMPEG_"....
Revert r14497 Log: Add missing header #includes.Policy violation (change not approved by maintainer)and while discussions where ongoing and no consensus has been reached.
Originally committed as revision 14500 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add missing header #includes.
Originally committed as revision 14497 to svn://svn.ffmpeg.org/ffmpeg/trunk
Make three rm demuxer functions non static.Patch by Ronald S. Bultje rsbultje gmail comOriginal thread: [FFmpeg-devel] [PATCH] Realmedia / RTSP (RDT)Date: 12/28/2007 10:19 PM
Originally committed as revision 11392 to svn://svn.ffmpeg.org/ffmpeg/trunk
Seek regression for RM demuxer fix
Originally committed as revision 10907 to svn://svn.ffmpeg.org/ffmpeg/trunk
Demux full frames instead of sliced for RealVideo.Some changes by Roberto Togni and blessed by him on IRC.
Originally committed as revision 10823 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add FFMPEG_ prefix to all multiple inclusion guards.
Originally committed as revision 10765 to svn://svn.ffmpeg.org/ffmpeg/trunk
split rm muxer and demuxer in their own files
Originally committed as revision 9156 to svn://svn.ffmpeg.org/ffmpeg/trunk