Rename rtp_payload_data_t to avoid clashes with the POSIX namespace
Originally committed as revision 16115 to svn://svn.ffmpeg.org/ffmpeg/trunk
Change function prototype of the sdp_parse_a_line in DynamicProtocolHandler.This function is called in rtsp.c for each a= line in the SDP of the Describeresponse after m= RTSP stream descriptors. The function prototype used totake an AVStream argument. For RDT, however, every RTSPStream represents...
Remove access into RTPDemuxContext in rtsp.c, which allows making it opaque(and thus preparing for the introduction of RDTDemuxContext) in a next patch.See discussion in "RDT/Realmedia patches #2" thread on ML.
Originally committed as revision 15542 to svn://svn.ffmpeg.org/ffmpeg/trunk
Change function prototype of RTPDynamicPayloadHandler.parse_packet() tonot use RTPDemuxContext, but rather take a pointer to the payload contextdirectly. This allows using payload handlers regardless over the transportover which they were sent, and prepares for the introduction of a future...
Rename RTP payload contexts to PayloadContext, suggested by Luca in"RDT/Realmedia patches #2" thread on ML.
Originally committed as revision 15540 to svn://svn.ffmpeg.org/ffmpeg/trunk
Give register_dynamic_payload_handler() in rtpdec.c a ff_ prefix and exportit so that I can use it in rdt.c as well. See discussion in "Realmedia patch" thread on ML.
Originally committed as revision 15233 to svn://svn.ffmpeg.org/ffmpeg/trunk
Globally rename the header inclusion guard names.
Consistently apply this rule: the guard name is obtained from thefilename by stripping the leading "lib", converting '/' and '.' to'_' and uppercasing the resulting name. Guard names in the rootdirectory have to be prefixed by "FFMPEG_"....
Use full path for #includes from another directory.
Originally committed as revision 13098 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add a flags field to the RTPDynamicPayloadPacketHandlerProc (PKT_FLAG_*).This can be used later by RDT to get the flags from the RTP packet anduse that for the RealMedia packet (such as whether this RTP packetrepresents a keyframe or not). For discussion, see "[PATCH] Realmedia...
Remove the "AVRtpPayloadTypes[i].pt == i" assumption from RTP and RTSPcode (this is needed for supporting MPEG2 video in the RTP muxer)
Originally committed as revision 11046 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add FFMPEG_ prefix to all multiple inclusion guards.
Originally committed as revision 10765 to svn://svn.ffmpeg.org/ffmpeg/trunk
Allow to set the maximum number of frames per RTP packet (and add support forthis in the AAC packetizer)
Originally committed as revision 10647 to svn://svn.ffmpeg.org/ffmpeg/trunk
move unrelated functions declarations out of allformats.h
Originally committed as revision 10475 to svn://svn.ffmpeg.org/ffmpeg/trunk
Move the RTP packetization code for MPEG12 video in its own file (rtp_mpv.c)
Originally committed as revision 10201 to svn://svn.ffmpeg.org/ffmpeg/trunk
include all prerequisites in header files
Originally committed as revision 9344 to svn://svn.ffmpeg.org/ffmpeg/trunk
add valid statistics for the RTCP receiver report.Basically taken verbatim from RFC 1889.Patch by Ryan Martell % rdm4 A martellventures P com %Original thread:Date: Oct 31, 2006 12:43 AMSubject: [Ffmpeg-devel] [PATCH] RTCP valid receiver statistics.......
fix more dynamic protocol stuff, needed by the forthcoming h264streaming patch.(Minor additions to give more information to the dynamic protocolhandlers, and a slight rearrangement of code.)Patch by Ryan Martell rdm4 A martellventures P comOriginal thread:...
make ffmpeg able to send back a RTCP receiver report.Patch by Thijs thijsvermeir A telenet P beOriginal thread:Date: Oct 27, 2006 12:58 PMSubject: [Ffmpeg-devel] [PATCH proposal] RTCP receiver report
Originally committed as revision 6805 to svn://svn.ffmpeg.org/ffmpeg/trunk
Last fix of licence header
Originally committed as revision 6801 to svn://svn.ffmpeg.org/ffmpeg/trunk
move licence header fixes
Originally committed as revision 6800 to svn://svn.ffmpeg.org/ffmpeg/trunk
Fix licence header (aka <pedantic mode='on' /> )
Originally committed as revision 6799 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add support for H264 over RTPPatch by Ryan Martell % rdm4 A martellventures P com Original thread:Date: Oct 9, 2006 4:55 PMSubject: [Ffmpeg-devel] RTP patches x%x RFCActual committed patch:Date: Oct 26, 2006 4:29 PM
Originally committed as revision 6798 to svn://svn.ffmpeg.org/ffmpeg/trunk