Statistics
| Branch: | Revision:

ffmpeg / libavformat / rtpdec_asf.c @ 4dcde00c

History | View | Annotate | Download (9.42 KB)

# Date Author Comment
6dc7d80d 04/03/2011 08:47 PM Anton Khirnov

avio: avio_ prefix for url_close_dyn_buf

b92c5452 04/03/2011 08:46 PM Anton Khirnov

avio: avio_ prefix for url_open_dyn_buf

2912e87a 03/19/2011 01:33 PM Mans Rullgard

Replace FFmpeg with Libav in licence headers

Signed-off-by: Mans Rullgard <>

45a8a02a 03/17/2011 02:24 AM Anton Khirnov

lavf: replace avio_seek(SEEK_CUR) with avio_skip where it makes sense

Signed-off-by: Ronald S. Bultje <>

a2704c97 03/04/2011 04:26 PM Anton Khirnov

avio: add avio_tell macro as a replacement for url_ftell

Signed-off-by: Ronald S. Bultje <>

e356fc57 03/01/2011 05:22 PM Anton Khirnov

lavf: replace all uses of url_fskip with avio_seek

Signed-off-by: Ronald S. Bultje <>

77eb5504 02/21/2011 07:25 PM Anton Khirnov

avio: avio: avio_ prefixes for put_* functions

In the name of consistency:
put_byte -> avio_w8
put_<type> -> avio_w<type>
put_buffer -> avio_write

put_nbyte will be made private
put_tag will be merged with avio_put_str

Signed-off-by: Ronald S. Bultje <>

b7effd4e 02/21/2011 04:23 PM Anton Khirnov

avio: avio_ prefixes for get_* functions

In the name of consistency:
get_byte -> avio_r8
get_<type> -> avio_r<type>
get_buffer -> avio_read

get_partial_buffer will be made private later

get_strz is left out becase I want to change it later to return...

e731b8d8 02/20/2011 01:37 PM Anton Khirnov

avio: move init_put_byte() to a new private header and rename it

init_put_byte should never be used outside of lavf, since
sizeof(AVIOContext) isn't part of public ABI.

Signed-off-by: Ronald S. Bultje <>

ae628ec1 02/20/2011 01:37 PM Anton Khirnov

avio: rename ByteIOContext to AVIOContext.

Signed-off-by: Ronald S. Bultje <>

44adbebe 02/10/2011 09:45 PM Mans Rullgard

Remove final semicolon from some macros

This avoids double semicolons after macro expansion.

Signed-off-by: Mans Rullgard <>

c6610a21 01/26/2011 10:10 PM Diego Elio Pettenò

Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.

This also lists the objects from those two libraries as internal (by adding
the ff_ prefix) so that they can then be hidden via linker scripts.

06ed024d 01/14/2011 07:44 PM Ronald S. Bultje

Copy metadata from ASF files contained in RTSP streams from ASF to RTSP layer,
so that applications can read it also.

Originally committed as revision 26332 to svn://svn.ffmpeg.org/ffmpeg/trunk

afbc4d2d 08/13/2010 08:06 PM Ronald S. Bultje

Prevent overflow on random input.

Originally committed as revision 24795 to svn://svn.ffmpeg.org/ffmpeg/trunk

965a3ddb 07/30/2010 12:04 PM Martin Storsjö

Remove mostly unnecessary rtpdec_*.h files, store the declarations in one file

Originally committed as revision 24596 to svn://svn.ffmpeg.org/ffmpeg/trunk

4f5340a0 07/21/2010 05:25 PM Martin Storsjö

Reindent, rewrap long comment lines to keep line length below 80 chars

Originally committed as revision 24390 to svn://svn.ffmpeg.org/ffmpeg/trunk

bcc4cb46 07/21/2010 05:17 PM Martin Storsjö

rtpdec_asf: Handle RTSP-MS packet splitting

Originally committed as revision 24389 to svn://svn.ffmpeg.org/ffmpeg/trunk

a16ebd40 07/19/2010 11:43 AM Martin Storsjö

rtpdec_asf: Include lavu headers using quotes instead of angle brackets

Originally committed as revision 24325 to svn://svn.ffmpeg.org/ffmpeg/trunk

0fca8d24 07/05/2010 04:46 PM Martin Storsjö

rtpdec_asf: Propagate errors from the chained av_open_input_stream

This fixes the crash in issue 2070.

Originally committed as revision 24059 to svn://svn.ffmpeg.org/ffmpeg/trunk

9b1947c7 06/27/2010 09:07 AM Eli Friedman

Fix implicit cast warning

Patch by Eli Friedman, eli dot friedman at gmail

Originally committed as revision 23817 to svn://svn.ffmpeg.org/ffmpeg/trunk

ba87f080 04/20/2010 02:45 PM Diego Biurrun

Remove explicit filename from Doxygen @file commands.

Passing an explicit filename to this command is only necessary if the
documentation in the @file block refers to a file different from the
one the block resides in.

Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk

72415b2a 03/30/2010 11:30 PM Stefano Sabatini

Define AVMediaType enum, and use it instead of enum CodecType, which
is deprecated and will be dropped at the next major bump.

Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk

f65919af 02/28/2010 11:03 AM Martin Storsjö

Rename RTP depacketizer files from rtp_* to rtpdec_*

Originally committed as revision 22109 to svn://svn.ffmpeg.org/ffmpeg/trunk