avio: move init_put_byte() to a new private header and rename it
init_put_byte should never be used outside of lavf, sincesizeof(AVIOContext) isn't part of public ABI.
Signed-off-by: Ronald S. Bultje <email@example.com>
avio: rename ByteIOContext to AVIOContext.
Remove final semicolon from some macros
This avoids double semicolons after macro expansion.
Signed-off-by: Mans Rullgard <firstname.lastname@example.org>
Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.
This also lists the objects from those two libraries as internal (by addingthe ff_ prefix) so that they can then be hidden via linker scripts.
Copy metadata from ASF files contained in RTSP streams from ASF to RTSP layer,so that applications can read it also.
Originally committed as revision 26332 to svn://svn.ffmpeg.org/ffmpeg/trunk
Prevent overflow on random input.
Originally committed as revision 24795 to svn://svn.ffmpeg.org/ffmpeg/trunk
Remove mostly unnecessary rtpdec_*.h files, store the declarations in one file
Originally committed as revision 24596 to svn://svn.ffmpeg.org/ffmpeg/trunk
Reindent, rewrap long comment lines to keep line length below 80 chars
Originally committed as revision 24390 to svn://svn.ffmpeg.org/ffmpeg/trunk
rtpdec_asf: Handle RTSP-MS packet splitting
Originally committed as revision 24389 to svn://svn.ffmpeg.org/ffmpeg/trunk
rtpdec_asf: Include lavu headers using quotes instead of angle brackets
Originally committed as revision 24325 to svn://svn.ffmpeg.org/ffmpeg/trunk
rtpdec_asf: Propagate errors from the chained av_open_input_stream
This fixes the crash in issue 2070.
Originally committed as revision 24059 to svn://svn.ffmpeg.org/ffmpeg/trunk
Fix implicit cast warning
Patch by Eli Friedman, eli dot friedman at gmail
Originally committed as revision 23817 to svn://svn.ffmpeg.org/ffmpeg/trunk
Remove explicit filename from Doxygen @file commands.
Passing an explicit filename to this command is only necessary if thedocumentation in the @file block refers to a file different from theone the block resides in.
Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
Define AVMediaType enum, and use it instead of enum CodecType, whichis deprecated and will be dropped at the next major bump.
Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
Rename RTP depacketizer files from rtp_* to rtpdec_*
Originally committed as revision 22109 to svn://svn.ffmpeg.org/ffmpeg/trunk