| Branch: | Revision:

ffmpeg / libavformat / rtsp.h @ 6a8c8b36

History | View | Annotate | Download (10.5 KB)

# Date Author Comment
9c610b76 03/21/2009 08:44 PM Ronald S. Bultje

Add a @todo item to use ByteIOContext instead of URLContext at some point in
the future, requested by Luca in "[PATCH] rtsp.c: read TCP server
notifications/messages" thread.

Originally committed as revision 18120 to svn://

1a30d541 03/17/2009 12:34 PM Ronald S. Bultje

Add RTP/ASF header parsing, which is part of the SDP of these streams. See
patch discussion in "[PATCH] RTSP-MS 10/15: ASF header parsing" thread.

Originally committed as revision 18023 to svn://

26d6b3e2 02/26/2009 02:15 PM Ronald S. Bultje

Document rtsp.h, see "[PATCH] document rtsp.h" thread.

Originally committed as revision 17614 to svn://

a9e534d5 02/21/2009 10:26 PM Ronald S. Bultje

Rename RTSPHeader to RTSPMessageHeader to reflect more clearly what the
structure is meant to represent. See "[PATCH] rtsp.[ch]: RTSPHeader ->
RTSPServerResponse" and "[PATCH] document rtsp.h" threads on ML.

Originally committed as revision 17504 to svn://

2a1d51c5 02/16/2009 04:27 PM Ronald S. Bultje

Rename RTSP_*_LAST to RTSP_*_NB in line with PIX_FMT_* in lavc. See "[PATCH]
document rtsp.h" mailinglist thread.

Originally committed as revision 17381 to svn://

3b0fc605 02/16/2009 04:24 PM Ronald S. Bultje

Don't install rtsp.h. It is intended to be private, it depends on rtp code
which isn't installed anyway (so it doesn't work).

In the process, also remove public/private API comments from rtsp headers
because they are unnecessary.

Originally committed as revision 17379 to svn://

302879cb 02/06/2009 10:35 AM Luca Abeni

Split rtp.h in rtp.h, rtpdec.h, and rtpenc.h

Originally committed as revision 17016 to svn://

0a861b6f 02/05/2009 10:34 PM Ronald S. Bultje

Rename "tx_ctx" and "cur_tx" variables to "transport_priv" and
"cur_transport_priv", as discussed in the "[PATCH] rtsp.h: rename tx
variables" thread.

Originally committed as revision 17012 to svn://

b516ecdd 02/05/2009 05:00 PM Ronald S. Bultje

Delete an enum and a function typedef that aren't used anywhere, and
move move a struct/typedef in rtsp.h that is only used in ffserver.c into
ffserver.c. See "[PATCH] rtsp.h: move/remove unused thingies" thread on ML.

Originally committed as revision 17005 to svn://

1262d638 02/04/2009 05:17 PM Ronald S. Bultje

Move enum RTSPTransport up a bit, so that all fields that are assigned a value
of this type can be properly attributed as such (in this case, transport in
the RTSPTransportField struct). See "[PATCH] RTSP-MS 10/15: ASF header parsing"
thread on mailinglist....

406792e7 01/19/2009 03:46 PM Diego Biurrun

cosmetics: Remove pointless period after copyright statement non-sentences.

Originally committed as revision 16684 to svn://

6e5f27ca 01/07/2009 04:01 PM Ronald S. Bultje

Fix typo ("Standard-compliant" -> "Standards-compliant"), as noticed by

Originally committed as revision 16475 to svn://

70d4b8ce 01/07/2009 03:13 PM Ronald S. Bultje

Fix doxy comments missing one '*'.

Originally committed as revision 16473 to svn://

7a86bafa 01/07/2009 02:55 PM Ronald S. Bultje

Use the "server" RTSP field to detect whether the server that we're talking
to is a Microsoft Windows Media Server (the field will be "WMServer/version").
See "[PATCH] RTSP-MS 3/15: Add Windows Media Server type" thread on

Originally committed as revision 16472 to svn://

74272b1c 01/07/2009 02:53 PM Ronald S. Bultje

Export RTSPState and RTSPStream from rtsp.c into rtsp.h. This allows future
access to these structures in functions that will be located in rtp_asf.c.
See "[PATCH] RTSP-MS 2/15: export RTSPState and RTSPStream" mailinglist

Originally committed as revision 16471 to svn://

119b4668 09/30/2008 01:26 PM Ronald S. Bultje

Implement a RTSPTransport field, which allows proper separation of server
types and their non-standard extensions, and the data they serve. Practically,
this patch allows Real servers to serve normal non-RDT (standard RTP) data.
See discussion on ML in "Realmedia patch" thread....

90abbdba 09/30/2008 01:18 PM Ronald S. Bultje

Rename RTSPProtocol to RTSPLowerTransport, so that its name properly tells us
that it only describes the lower-level transport (TCP vs. UDP) and not the
actual data layout (e.g. RDT vs. RTP). See discussion in "Realmedia patch"
thread on ML.

Originally committed as revision 15481 to svn://

30aa6aed 08/31/2008 05:32 PM Ronald S. Bultje

Read RealChallenge1 field from the server.

Originally committed as revision 15124 to svn://

75128a22 08/31/2008 05:23 PM Ronald S. Bultje

Revert back to old version (r15103).

Originally committed as revision 15122 to svn://

98790382 08/31/2008 07:39 AM Stefano Sabatini

Globally rename the header inclusion guard names.

Consistently apply this rule: the guard name is obtained from the
filename by stripping the leading "lib", converting '/' and '.' to
'_' and uppercasing the resulting name. Guard names in the root
directory have to be prefixed by "FFMPEG_"....

158efd74 08/31/2008 03:12 AM Ronald S. Bultje

Implement RTSP/Realmedia-compatible OPTIONS command. See "Realmedia patch"
thread on mailinglist for discussion. This patch also implements a
RTSPServerType enum, which allows the RTSP to keep track of what kind of a
stream we're handling: standard-compliant RTP or a proprietary derivative....

8a8754d8 03/19/2008 02:05 PM Ronald S. Bultje

Allow cycling between different protocols (TCP, UDP or multicast) so that if
one doesn't work, we can try the next one (i.e. trial-error protocol auto-

Discussed and approved in "[PATCH] RTSP alternate protocol 2-3/3".

Originally committed as revision 12504 to svn://

c482500f 01/02/2008 07:40 PM Ronald S. Bultje

Drop RTSP default protocol.
patch by Ronald S. Bultje, rsbultje gmail com

Originally committed as revision 11377 to svn://

5b21bdab 10/17/2007 09:37 AM Diego Biurrun

Add FFMPEG_ prefix to all multiple inclusion guards.

Originally committed as revision 10765 to svn://

b156b88c 09/10/2007 10:48 PM Aurelien Jacobs

rtp and rtsp demuxer declarations are not part of public API

Originally committed as revision 10474 to svn://

99545457 06/16/2007 10:59 PM Måns Rullgård

include all prerequisites in header files

Originally committed as revision 9344 to svn://

0913873e 04/26/2007 05:38 PM Alex Beregszaszi

remove unused rtsp_callback

Originally committed as revision 8832 to svn://

50c5f159 03/05/2007 01:54 PM Panagiotis Issaris

Make rtsp_set_callback() comments available to Doxygen

Originally committed as revision 8257 to svn://

0af4407d 03/05/2007 01:53 PM Panagiotis Issaris

Move unaltered rtsp.c comments to the header file.

Originally committed as revision 8256 to svn://

37d2210a 03/05/2007 01:53 PM Panagiotis Issaris

Doxygenize comments in rtsp.h

Originally committed as revision 8255 to svn://

391fbb65 03/05/2007 01:52 PM Panagiotis Issaris

Convert macro+enum into a simple enum: Currently the enum was filled using a
macro that also contained a description for every field, but, that description
was not being used anywhere. This changes it, to make the description available
as a Doxygen comment. Furthermore, it is now easily parsable by Doxygen, while...

b78e7197 10/07/2006 03:30 PM Diego Biurrun

Change license headers to say 'FFmpeg' instead of 'this program/this library'
and fix GPL/LGPL version mismatches.

Originally committed as revision 6577 to svn://

d2a067d1 07/09/2006 11:40 PM Måns Rullgård

give AVInput/OutputFormat structs consistent names

Originally committed as revision 5697 to svn://

5509bffa 01/12/2006 10:43 PM Diego Biurrun

Update licensing information: The FSF changed postal address.

Originally committed as revision 4842 to svn://

115329f1 12/17/2005 06:14 PM Diego Biurrun

COSMETICS: Remove all trailing whitespace.

Originally committed as revision 4749 to svn://

d1ccf0e0 05/26/2005 07:47 AM Romain Degez

RTP/RTSP and MPEG4-AAC audio
- preliminary support for mpeg4-aac rtp payload (no interleaving support)
- use udp transport as default (makes more sense with rtp, doesn't it ?)
- some code factorization, so adding support for new rtp payload will be easier...

ff762d6e 11/10/2003 06:39 PM Fabrice Bellard

initial seek support - more generic play/pause support

Originally committed as revision 2495 to svn://

b7b8fc34 07/17/2003 10:27 AM Fabrice Bellard

suppressed RTSP abort hack - added PLAY/PAUSE

Originally committed as revision 2060 to svn://

0c1a9eda 02/11/2003 04:35 PM Zdenek Kabelac
  • UINTX -> uintx_t INTX -> intx_t

Originally committed as revision 1578 to svn://

abac6175 11/25/2002 07:07 PM Fabrice Bellard

renamed libav to libavformat

Originally committed as revision 1276 to svn://