Replace FFmpeg with Libav in licence headers
Signed-off-by: Mans Rullgard <email@example.com>
avio: add avio_tell macro as a replacement for url_ftell
Signed-off-by: Ronald S. Bultje <firstname.lastname@example.org>
avio: avio_ prefix for url_fseek
avio: avio_ prefixes for get_* functions
In the name of consistency:get_byte -> avio_r8get_<type> -> avio_r<type>get_buffer -> avio_read
get_partial_buffer will be made private later
get_strz is left out becase I want to change it later to return...
avio: rename ByteIOContext to AVIOContext.
Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.
This also lists the objects from those two libraries as internal (by addingthe ff_ prefix) so that they can then be hidden via linker scripts.
Remove explicit filename from Doxygen @file commands.
Passing an explicit filename to this command is only necessary if thedocumentation in the @file block refers to a file different from theone the block resides in.
Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
Define AVMediaType enum, and use it instead of enum CodecType, whichis deprecated and will be dropped at the next major bump.
Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use full internal pathname in doxygen @file directives.Otherwise doxygen complains about ambiguous filenames when files existunder the same name in different subdirectories.
Originally committed as revision 16912 to svn://svn.ffmpeg.org/ffmpeg/trunk
Fix build: Add intreadwrite.h and bswap.h #includes where necessary.
Originally committed as revision 16556 to svn://svn.ffmpeg.org/ffmpeg/trunk
The POSIX namespace shall be held sacrosanct. To that end,continue eliminating _t from structure names in FFmpeg.
Originally committed as revision 16118 to svn://svn.ffmpeg.org/ffmpeg/trunk
Remove offset_t typedef and use int64_t directly instead.The name offset_t is easily confused with the standard off_t type and*_t is POSIX reserved namespace if any POSIX header is included.
Originally committed as revision 15533 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use enum typers instead of int.Patch by Diego 'Flameeyes' Pettenò: flameeyes gmail
Originally committed as revision 15517 to svn://svn.ffmpeg.org/ffmpeg/trunk
Bump Major version, this commit is almost just renaming bits_per_sample tobits_per_coded_sample but that cannot be done seperately.Patch by Luca AbeniAlso reset the minor version and fix the forgotton change to libfaad.Note: The API/ABI should not be considered stable yet, there still may...
Make long_names in lavf/lavdev optional depending on CONFIG_SMALL.patch by Stefano Sabatini, stefano.sabatini-lala poste.italong with some spelling/consistency fixes for the long names by me
Originally committed as revision 13649 to svn://svn.ffmpeg.org/ffmpeg/trunk
Originally committed as revision 12153 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use dynamically allocated ByteIOContext in AVFormatContext
patch by: Björn Axelsson, bjorn d axelsson a intinor d sethread: [PATCH] Remove static ByteIOContexts, 06 nov 2007
Originally committed as revision 11071 to svn://svn.ffmpeg.org/ffmpeg/trunk
Replace all occurrences of AVERROR_IO with AVERROR.
Originally committed as revision 9760 to svn://svn.ffmpeg.org/ffmpeg/trunk
Replace all occurrences of AVERROR_NOMEM with AVERROR.
Originally committed as revision 9759 to svn://svn.ffmpeg.org/ffmpeg/trunk
Get rid of unnecessary pointer casts.patch by Nicholas Tung, ntung ntung com
Originally committed as revision 8687 to svn://svn.ffmpeg.org/ffmpeg/trunk
allocate 32 extra bytes at the end of the probe buffer and remove most probe buf_size checks
Originally committed as revision 8677 to svn://svn.ffmpeg.org/ffmpeg/trunk
rename BE/LE_8/16/32 to AV_RL/B_8/16/32
Originally committed as revision 7587 to svn://svn.ffmpeg.org/ffmpeg/trunk
Simplify the Sega FILM/CPK demuxer to not modify the bastardized Cinepak stream.I changes the lavc Cinepak decoder some time ago to be able to handle the deviantdata, but never updated this demuxer.
Originally committed as revision 7214 to svn://svn.ffmpeg.org/ffmpeg/trunk
Change license headers to say 'FFmpeg' instead of 'this program/this library'and fix GPL/LGPL version mismatches.
Originally committed as revision 6577 to svn://svn.ffmpeg.org/ffmpeg/trunk
allow individual selection of muxers and demuxers
Originally committed as revision 5707 to svn://svn.ffmpeg.org/ffmpeg/trunk
give AVInput/OutputFormat structs consistent names
Originally committed as revision 5697 to svn://svn.ffmpeg.org/ffmpeg/trunk
Update licensing information: The FSF changed postal address.
Originally committed as revision 4842 to svn://svn.ffmpeg.org/ffmpeg/trunk
COSMETICS: Remove all trailing whitespace.
Originally committed as revision 4749 to svn://svn.ffmpeg.org/ffmpeg/trunk
changing AVCodecContext codec -> *codec in AVStream so additions to AVCodecContext dont randomize AVStream and break binary compatibility
Originally committed as revision 4453 to svn://svn.ffmpeg.org/ffmpeg/trunk
Originally committed as revision 4314 to svn://svn.ffmpeg.org/ffmpeg/trunk
various security fixes and precautionary checks
Originally committed as revision 3822 to svn://svn.ffmpeg.org/ffmpeg/trunk
integer overflows, heap corruptionpossible arbitrary code execution cannot be ruled out in some casesprecautionary checks
Originally committed as revision 3813 to svn://svn.ffmpeg.org/ffmpeg/trunk
sweeping change from -EIO -> AVERROR_IO
Originally committed as revision 3239 to svn://svn.ffmpeg.org/ffmpeg/trunk
move time_base (pts_num/pts_den) from AVFormatContext -> AVStream
Originally committed as revision 3148 to svn://svn.ffmpeg.org/ffmpeg/trunk
remove numerous definitions of BE_*/LE_* macros; convert FOURCC_TAG ->MKTAG/MKBETAG
Originally committed as revision 2886 to svn://svn.ffmpeg.org/ffmpeg/trunk
the correct data type is offset_t
Originally committed as revision 2329 to svn://svn.ffmpeg.org/ffmpeg/trunk
New demuxers: Sega FILM/CPK, Westwood VQA & AUD; new decoders: MS RLE &Video-1, Apple RPZA, Cinepak, Westwood IMA ADPCM
Originally committed as revision 2324 to svn://svn.ffmpeg.org/ffmpeg/trunk