| Branch: | Revision:

ffmpeg / libavformat / swfenc.c @ acaceca2

History | View | Annotate | Download (15.6 KB)

# Date Author Comment
8978feda 04/03/2011 08:46 PM Anton Khirnov

avio: introduce an AVIOContext.seekable field

Use it instead of url_is_streamed and AVIOContext.is_streamed.

2912e87a 03/19/2011 01:33 PM Mans Rullgard

Replace FFmpeg with Libav in licence headers

Signed-off-by: Mans Rullgard <>

b7f2fdde 03/17/2011 02:59 AM Anton Khirnov

avio: rename put_flush_packet -> avio_flush

Signed-off-by: Ronald S. Bultje <>

a2704c97 03/04/2011 04:26 PM Anton Khirnov

avio: add avio_tell macro as a replacement for url_ftell

Signed-off-by: Ronald S. Bultje <>

6b4aa5da 03/01/2011 05:12 PM Anton Khirnov

avio: avio_ prefix for url_fseek

Signed-off-by: Ronald S. Bultje <>

bbc413f9 02/25/2011 07:38 PM Anton Khirnov

lavf: replace remaining uses of put_tag with avio_write

Signed-off-by: Ronald S. Bultje <>

77eb5504 02/21/2011 07:25 PM Anton Khirnov

avio: avio: avio_ prefixes for put_* functions

In the name of consistency:
put_byte -> avio_w8
put_<type> -> avio_w<type>
put_buffer -> avio_write

put_nbyte will be made private
put_tag will be merged with avio_put_str

Signed-off-by: Ronald S. Bultje <>

ae628ec1 02/20/2011 01:37 PM Anton Khirnov

avio: rename ByteIOContext to AVIOContext.

Signed-off-by: Ronald S. Bultje <>

c6610a21 01/26/2011 10:10 PM Diego Elio Pettenò

Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.

This also lists the objects from those two libraries as internal (by adding
the ff_ prefix) so that they can then be hidden via linker scripts.

72415b2a 03/30/2010 11:30 PM Stefano Sabatini

Define AVMediaType enum, and use it instead of enum CodecType, which
is deprecated and will be dropped at the next major bump.

Originally committed as revision 22735 to svn://

1a40491e 06/22/2009 11:09 PM Daniel Verkamp

Add ff_ prefixes to exported symbols in libavformat/riff.h.
patch by Daniel Verkamp, aniel drv nu

Originally committed as revision 19254 to svn://

ec6b02b6 05/21/2009 11:12 PM Baptiste Coudurier

check av_fifo_alloc return

Originally committed as revision 18892 to svn://

fb53b4a0 04/13/2009 04:59 PM Stefano Sabatini

Rename pbBufPtr() to put_bits_ptr().
The new name is more readable and consistent with the FFmpeg naming

Originally committed as revision 18497 to svn://

b2755007 04/12/2009 08:35 AM Stefano Sabatini

Split bitstream.h, put the bitstream writer stuff in the new file

Originally committed as revision 18461 to svn://

3898eed8 03/09/2009 05:47 PM Reimar Döffinger

Reorder arguments for av_fifo_generic_read to be more logical and
consistent with av_fifo_generic_write.

Originally committed as revision 17914 to svn://

41dd680d 03/08/2009 02:16 PM Michael Niedermayer

Allocate AVFifoBuffer through the fifo API to reduce future API/ABI issues.
Yes this breaks ABI/API but ive already broken it and will bump avutil major

Originally committed as revision 17869 to svn://

6bab4799 02/08/2009 03:44 AM Diego Biurrun

Remove const qualifier from function argument to eliminate the warning
swfenc.c:452: warning: passing argument 2 of #av_fifo_generic_write# discards qualifiers from pointer target type

Originally committed as revision 17036 to svn://

406792e7 01/19/2009 03:46 PM Diego Biurrun

cosmetics: Remove pointless period after copyright statement non-sentences.

Originally committed as revision 16684 to svn://

b250f9c6 01/13/2009 11:44 PM Aurelien Jacobs

Change semantic of CONFIG_*, HAVE_* and ARCH_*.
They are now always defined to either 0 or 1.

Originally committed as revision 16590 to svn://

bc5c918e 10/03/2008 10:16 AM Diego Biurrun

Remove offset_t typedef and use int64_t directly instead.
The name offset_t is easily confused with the standard off_t type and
*_t is POSIX reserved namespace if any POSIX header is included.

Originally committed as revision 15533 to svn://

9b92ed76 07/19/2008 03:25 AM Baptiste Coudurier

update swf video frame number when muxing done, fix #439

Originally committed as revision 14293 to svn://

bde15e74 06/03/2008 04:20 PM Stefano Sabatini

Make long_names in lavf/lavdev optional depending on CONFIG_SMALL.
patch by Stefano Sabatini, stefano.sabatini-lala
along with some spelling/consistency fixes for the long names by me

Originally committed as revision 13649 to svn://

efb53331 05/27/2008 10:37 PM Baptiste Coudurier

use internal video frame number

Originally committed as revision 13479 to svn://

f2ecb775 05/27/2008 10:34 PM Baptiste Coudurier


Originally committed as revision 13478 to svn://

92f76fbf 05/27/2008 10:31 PM Baptiste Coudurier

simplify, use pointer to codec context in struct instead of only id

Originally committed as revision 13476 to svn://

ed03be6c 05/27/2008 04:33 AM Baptiste Coudurier

use AVFifoBuffer

Originally committed as revision 13462 to svn://

2aaf590b 05/27/2008 03:42 AM Baptiste Coudurier


Originally committed as revision 13461 to svn://

11dae336 05/27/2008 03:41 AM Baptiste Coudurier

merge init and declaration

Originally committed as revision 13460 to svn://

4a712c33 05/27/2008 03:11 AM Baptiste Coudurier

simplify and use version instead

Originally committed as revision 13459 to svn://

6ef445fe 05/27/2008 03:00 AM Baptiste Coudurier


Originally committed as revision 13458 to svn://

8d4f0e67 05/27/2008 02:57 AM Baptiste Coudurier


Originally committed as revision 13457 to svn://

9caf6781 05/27/2008 02:55 AM Baptiste Coudurier

cosmetics, remove useless cases and braces

Originally committed as revision 13456 to svn://

58c37c30 05/26/2008 03:56 AM Baptiste Coudurier

cosmetics, remove useless dot

Originally committed as revision 13421 to svn://

3e67f255 05/20/2008 11:39 PM Baptiste Coudurier

remove useless/obsolete comments

Originally committed as revision 13205 to svn://

3b35f4ab 05/20/2008 11:31 PM Baptiste Coudurier

split swf de/muxer

Originally committed as revision 13203 to svn://