Replace FFmpeg with Libav in licence headers
Signed-off-by: Mans Rullgard <email@example.com>
lavf: replace avio_seek(SEEK_CUR) with avio_skip where it makes sense
Signed-off-by: Ronald S. Bultje <firstname.lastname@example.org>
lavf: replace all uses of url_fskip with avio_seek
avio: avio_ prefixes for get_* functions
In the name of consistency:get_byte -> avio_r8get_<type> -> avio_r<type>get_buffer -> avio_read
get_partial_buffer will be made private later
get_strz is left out becase I want to change it later to return...
avio: rename ByteIOContext to AVIOContext.
Prefix all _demuxer, _muxer, _protocol from libavformat and libavdevice.
This also lists the objects from those two libraries as internal (by addingthe ff_ prefix) so that they can then be hidden via linker scripts.
Remove explicit filename from Doxygen @file commands.
Passing an explicit filename to this command is only necessary if thedocumentation in the @file block refers to a file different from theone the block resides in.
Originally committed as revision 22921 to svn://svn.ffmpeg.org/ffmpeg/trunk
Define AVMediaType enum, and use it instead of enum CodecType, whichis deprecated and will be dropped at the next major bump.
Originally committed as revision 22735 to svn://svn.ffmpeg.org/ffmpeg/trunk
Fix memory leak for truncated frames
Originally committed as revision 21901 to svn://svn.ffmpeg.org/ffmpeg/trunk
Add more sanity checks for header elements, rejecting files with clearlyinvalid values that wouldn't play right anyway and reduce probe score to MAX/2.Passes probetest v2.
Originally committed as revision 19842 to svn://svn.ffmpeg.org/ffmpeg/trunk
Use full internal pathname in doxygen @file directives.Otherwise doxygen complains about ambiguous filenames when files existunder the same name in different subdirectories.
Originally committed as revision 16912 to svn://svn.ffmpeg.org/ffmpeg/trunk
Fix build: Add intreadwrite.h and bswap.h #includes where necessary.
Originally committed as revision 16556 to svn://svn.ffmpeg.org/ffmpeg/trunk
Bump Major version, this commit is almost just renaming bits_per_sample tobits_per_coded_sample but that cannot be done seperately.Patch by Luca AbeniAlso reset the minor version and fix the forgotton change to libfaad.Note: The API/ABI should not be considered stable yet, there still may...
Make long_names in lavf/lavdev optional depending on CONFIG_SMALL.patch by Stefano Sabatini, stefano.sabatini-lala poste.italong with some spelling/consistency fixes for the long names by me
Originally committed as revision 13649 to svn://svn.ffmpeg.org/ffmpeg/trunk
Maxis XA demuxer and decoder.Patch by Robert Marston rmarston (\at/) gmail point comOriginal thread: [FFmpeg-soc] [Patch] Maxis EA XA decoder - GSoC TaskDate: 04/08/2008 01:36 AM
Originally committed as revision 12817 to svn://svn.ffmpeg.org/ffmpeg/trunk