Clean up av_get_cpu_flag()
Instead of defining functions in per-arch header files includedby the main cpu.c, define them normally and call them from thegeneric one.
Originally committed as revision 25084 to svn://svn.ffmpeg.org/ffmpeg/trunk
Move mm_support() from libavcodec to libavutil, make it a publicfunction and rename it to av_get_cpu_flags().
Originally committed as revision 25076 to svn://svn.ffmpeg.org/ffmpeg/trunk
Sort AV_CPU_FLAG* by value.
Originally committed as revision 25047 to svn://svn.ffmpeg.org/ffmpeg/trunk
Originally committed as revision 25046 to svn://svn.ffmpeg.org/ffmpeg/trunk
Rename FF_MM_ symbols related to CPU features flags as AV_CPU_FLAG_symbols, and move them from libavcodec/avcodec.h to libavutil/cpu.h.
Originally committed as revision 25040 to svn://svn.ffmpeg.org/ffmpeg/trunk