| Branch: | Revision:

ffmpeg / libavutil / pixdesc.h @ 2912e87a

History | View | Annotate | Download (6.46 KB)

# Date Author Comment
2912e87a 03/19/2011 01:33 PM Mans Rullgard

Replace FFmpeg with Libav in licence headers

Signed-off-by: Mans Rullgard <>

bb4afa13 12/04/2010 12:56 PM Stefano Sabatini

Deprecate avcodec_pix_fmt_string() in favor of
av_get_pix_fmt_string(), added to libavutil/pixdesc.h.

Originally committed as revision 25879 to svn://

ee435580 07/08/2010 10:05 PM Stefano Sabatini

Reindent after r24101.

Originally committed as revision 24126 to svn://

ce1cd1cb 07/07/2010 11:41 PM Stefano Sabatini

Rename read/write_line() to av_read/write_image_line().

The old names were not av_ prefixed, and they were causing linking
failure on many platforms. The new names are also more descriptive.

Patch by Stefano Sabatini.

Originally committed as revision 24101 to svn://

9a58234f 07/02/2010 10:49 AM Diego Biurrun

Fix misspelled parameter names in Doxygen documentation.
This fixes one Doxygen warning each.

Originally committed as revision 23970 to svn://

49bd8e4b 06/30/2010 03:38 PM Måns Rullgård

Fix grammar errors in documentation

Originally committed as revision 23904 to svn://

f47a7cb7 02/16/2010 08:17 PM Stefano Sabatini

Move read_line() and write_line() definition from pixdesc.h to
pixdesc.c, which are now not anymore marked as static inline.

Fix the inclusion of the private header intreadwrite.h in the public
header pixdesc.h.

Originally committed as revision 21854 to svn://

351aff72 01/31/2010 05:13 PM Stefano Sabatini

Fix grammar: write to DST THING -> write THING to DST.

Originally committed as revision 21576 to svn://

80a07f6e 01/30/2010 06:50 PM Stefano Sabatini

Implement av_get_pix_fmt(), and deprecate avcodec_get_pix_fmt().

Originally committed as revision 21545 to svn://

60fa9568 11/23/2009 08:14 PM Stefano Sabatini

Clarify PIX_FMT_BE flag doxy. Increase consistency / pickiness.

Originally committed as revision 20592 to svn://

357561e7 11/18/2009 10:32 PM Stefano Sabatini

Clarify relations between log2_chroma_w, log2_chroma_h and comp.

Originally committed as revision 20550 to svn://

b8873c2a 11/18/2009 12:07 AM Stefano Sabatini

Rename AVPixFmtDescriptor.nb_channels to nb_components, the new name
is more clear and lexically more consistent with API and

Originally committed as revision 20545 to svn://

51135d1d 10/27/2009 08:56 PM Stefano Sabatini

Move pixdesc.{h,c} from libavcodec to libavutil.

This way pixdescs can be used without requiring a dependency on

Originally committed as revision 20389 to svn://