Revision bd8e7503 configure

View differences:

configure
169 169
                           and libraw1394 [no]
170 170
  --enable-libdirac        enable Dirac support via libdirac [no]
171 171
  --enable-libfaac         enable FAAC support via libfaac [no]
172
  --enable-libfreetype     enable libfreetype [no]
172 173
  --enable-libgsm          enable GSM support via libgsm [no]
173 174
  --enable-libmp3lame      enable MP3 encoding via libmp3lame [no]
174 175
  --enable-libnut          enable NUT (de)muxing via libnut,
......
897 898
    libdc1394
898 899
    libdirac
899 900
    libfaac
901
    libfreetype
900 902
    libgsm
901 903
    libmp3lame
902 904
    libnut
......
1043 1045
    llrintf
1044 1046
    local_aligned_16
1045 1047
    local_aligned_8
1048
    localtime_r
1046 1049
    log2
1047 1050
    log2f
1048 1051
    loongson
......
1425 1428
# filters
1426 1429
blackframe_filter_deps="gpl"
1427 1430
cropdetect_filter_deps="gpl"
1431
drawtext_filter_deps="libfreetype"
1428 1432
frei0r_filter_deps="frei0r dlopen strtok_r"
1429 1433
frei0r_src_filter_deps="frei0r dlopen strtok_r"
1430 1434
hqdn3d_filter_deps="gpl"
......
2740 2744
check_struct "sys/time.h sys/resource.h" "struct rusage" ru_maxrss
2741 2745
check_func  inet_aton $network_extralibs
2742 2746
check_func  isatty
2747
check_func  localtime_r
2743 2748
check_func  ${malloc_prefix}memalign            && enable memalign
2744 2749
check_func  mkstemp
2745 2750
check_func  mmap
......
2826 2831
                      require  libdirac libdirac_decoder/dirac_parser.h dirac_decoder_init $(pkg-config --libs dirac) &&
2827 2832
                      require  libdirac libdirac_encoder/dirac_encoder.h dirac_encoder_init $(pkg-config --libs dirac)
2828 2833
enabled libfaac    && require2 libfaac "stdint.h faac.h" faacEncGetVersion -lfaac
2834
enabled libfreetype && add_cflags $(pkg-config --cflags freetype2) && require libfreetype ft2build.h FT_Init_FreeType -lfreetype
2829 2835
enabled libgsm     && require  libgsm gsm/gsm.h gsm_create -lgsm
2830 2836
enabled libmp3lame && require  "libmp3lame >= 3.98.3" lame/lame.h lame_set_VBR_quality -lmp3lame
2831 2837
enabled libnut     && require  libnut libnut.h nut_demuxer_init -lnut

Also available in: Unified diff